summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2018-03-31 17:55:02 -0400
committerGI_Jack2018-03-31 17:55:02 -0400
commit2c3d0171d61ab2c3fcbea9a1fb14ca569ae8f31d (patch)
treeb9fff36d175ca46208bb9d95a89b7acc20052cb2
downloadaur-2c3d0171d61ab2c3fcbea9a1fb14ca569ae8f31d.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8964dfdb0307
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Mar 31 21:50:19 UTC 2018
+pkgbase = creds.py-git
+ pkgdesc = Harvest FTP/POP/IMAP/HTTP/IRC credentials along with interesting data from each of the protocols.
+ pkgver = r17.1ec8297
+ pkgrel = 1
+ url = https://github.com/DanMcInerney/creds.py
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = python2
+ depends = scapy
+ provides = creds.py
+ source = git+https://github.com/DanMcInerney/creds.py.git
+ md5sums = SKIP
+
+pkgname = creds.py-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82e08a5b3815
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: GI_Jack <iamjacksemail@hackermail.com>
+# Poached from Arch Strike
+# Original: ArchStrike <team@archstrike.org>
+
+pkgname=creds.py-git
+pkgver=r17.1ec8297
+pkgrel=1
+pkgdesc="Harvest FTP/POP/IMAP/HTTP/IRC credentials along with interesting data from each of the protocols."
+arch=('any')
+url='https://github.com/DanMcInerney/creds.py'
+license=('GPL2')
+depends=('scapy')
+makedepends=('git' 'python2')
+provides=('creds.py')
+source=("git+https://github.com/DanMcInerney/creds.py.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/creds.py"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare(){
+ grep -iRl 'python' "$srcdir/creds.py" | xargs sed -i 's|#!.*/usr/bin/python|#!/usr/bin/python2|;s|#!.*/usr/bin/env python$|#!/usr/bin/env python2|'
+}
+
+package() {
+ cd "$srcdir/creds.py"
+
+ # Make base directories.
+ install -Dm644 README.md "$pkgdir/usr/share/licenses/creds.py-git"
+ install -Dm755 creds.py "$pkgdir/usr/bin/creds.py"
+
+}