summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHannes Guedelhoefer2021-08-27 18:22:50 +0200
committerHannes Guedelhoefer2021-08-27 18:22:50 +0200
commit92b4d4a60d146f12f1f4c1564052ac98d4b2c718 (patch)
tree920e9e60a28b54a31fef8c11674f2a0fb4b51ede
parent1b7164e05bf9cea6b286b61724e35b4cec0918fa (diff)
downloadaur-92b4d4a60d146f12f1f4c1564052ac98d4b2c718.tar.gz
:bug: Fix working dir
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8cb05701c35..d0dbf04a6821 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,21 +12,25 @@ url="https://creekey.io"
license=('UNLICENSED')
prepare() {
+ cd "creekey-cli"
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {
+ cd "creekey-cli"
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
cargo build --frozen --release --all-features
}
check () {
+ cd "creekey-cli"
export RUSTUP_TOOLCHAIN=stable
cargo test --frozen --all-features
}
package() {
+ cd "creekey-cli"
find target/release \
-maxdepth 1 \
-executable \