summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHannes Guedelhoefer2021-08-27 17:57:13 +0200
committerHannes Guedelhoefer2021-08-27 17:57:13 +0200
commitce5515c23ff2c16568ec9eae3a04cac2498b8ada (patch)
tree57487778e42876086d7388846242ee0a2f879a64
downloadaur-ce5515c23ff2c16568ec9eae3a04cac2498b8ada.tar.gz
:tada:
-rw-r--r--.SRCINFO15
-rw-r--r--LICENSE1
-rw-r--r--PKGBUILD36
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1fd940d0228c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = creekey-git
+ pkgdesc = Story your Private Keys on your Phone!
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://creekey.io
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = UNLICENSED
+ makedepends = cargo
+ source = https://github.com/opencreek/creekey-cli
+ sha256sums = 9741628a1b164e9ec16170ae8b4f43b3e7473158b3bf12e49472c907d35d4731
+
+pkgname = creekey-git
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..5d1d4073eae1
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1 @@
+ALL RIGHTS RESERVED. Opencreek Technogoly UG 2021
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a49f7f1a50f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Opencreek Technogoly UG <hannes@opencreek.tech>
+pkgname=creekey-git
+pkgver=0.1.0
+pkgrel=1
+makedepends=('cargo')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+pkgdesc="Story your Private Keys on your Phone!"
+# source=("$pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$pkgname/$pkgname-$pkgver.crate")
+source=("https://github.com/opencreek/creekey-cli")
+sha256sums=('9741628a1b164e9ec16170ae8b4f43b3e7473158b3bf12e49472c907d35d4731')
+
+url="https://creekey.io"
+license=('UNLICENSED')
+
+prepare() {
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check () {
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+
+package() {
+ find target/release \
+ -maxdepth 1 \
+ -executable \
+ -type f \
+ -exec install -Dm0755 -t "$pkgdir/usr/bin/" {} +
+}