summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHannes Guedelhoefer2021-08-30 10:44:15 +0200
committerHannes Guedelhoefer2021-08-30 10:44:15 +0200
commitd1cc403b7d31ce062999eed48dac728146e237bf (patch)
treeaec8c6a038fc6c598000228648ad0d3ba2f0aee4
parent48a54f71da737fe5172dffaba7c6578dda4ce58d (diff)
downloadaur-d1cc403b7d31ce062999eed48dac728146e237bf.tar.gz
:sparkles: Add auto building head
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ef47027f654..6be013d04021 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = creekey-git
pkgdesc = Story your Private Keys on your Phone!
- pkgver = 0.1.0
- pkgrel = 3
+ pkgver = 0.1.0_r108.82b4efe
+ pkgrel = 1
url = https://creekey.io
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index d13ccb1b5b51..aa927328a50b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Opencreek Technogoly UG <hannes@opencreek.tech>
pkgname=creekey-git
-pkgver=0.1.0
-pkgrel=3
+pkgver=0.1.0_r108.82b4efe
+pkgrel=1
makedepends=('git' 'cargo')
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
pkgdesc="Story your Private Keys on your Phone!"
@@ -10,6 +10,11 @@ source=("git+https://github.com/opencreek/creekey-cli.git#branch=main")
url="https://creekey.io"
license=('UNLICENSED')
+pkgver() {
+ cd "creekey-cli"
+
+ printf "0.1.0_r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
prepare() {
cd "creekey-cli"