aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorakuma2020-03-15 17:36:36 +0000
committerakuma2020-03-15 17:36:36 +0000
commit719e9f89dfc7dfad7d9bd5a07aab327e0d093982 (patch)
tree4adb5206b8217aef6df6bf371f55713da95dcc21
downloadaur-719e9f89dfc7dfad7d9bd5a07aab327e0d093982.tar.gz
Initialize creep2 for AUR
-rw-r--r--.SRCINFO13
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD17
-rw-r--r--README.md42
-rwxr-xr-xcreep2.ttfbin0 -> 11724 bytes
5 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0beb8d13158
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = creep2
+ pkgdesc = A pretty sweet version of the creep pixel font for terminals without negative spacing support.
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/akuma-dev/creep2
+ arch = any
+ license = MIT
+ makedepends = git
+ source = git+https://github.com/akuma-dev/creep2.git
+ md5sums = SKIP
+
+pkgname = creep2
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..2851f9c16946
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+The MIT License (MIT)
+
+Copyright (c) 2014 Romeo Van Snick
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the "Software"), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software is furnished to do so,
+subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
+FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
+COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..295a7eb27bb8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Majid Butler <majidbutler@akuma-dev.com>
+pkgname=creep2
+pkgver=1.2
+pkgrel=1
+pkgdesc="A pretty sweet version of the creep pixel font for terminals without negative spacing support."
+arch=('any')
+url="https://github.com/akuma-dev/creep2"
+license=('MIT')
+source=("git+https://github.com/akuma-dev/creep2.git")
+makedepends=('git')
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/creep2"
+ install -D -m644 creep2.ttf "$pkgdir/usr/share/fonts/misc/creep2.ttf"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..282a118a3acb
--- /dev/null
+++ b/README.md
@@ -0,0 +1,42 @@
+# THIS FONT WAS NOT MADE BY ME. I DO NOT TAKE CREDIT FOR ITS CREATION. THE ORIGINAL FONT AND ITS MODIFIED CAN BE FOUND HERE:
+(Original): https://github.com/romeovs/creep
+(Modified): https://github.com/raymond-w-ko/creep2
+
+# A copy of the 'creep' font by romeovs but with a strict character bounding box
+
+## Notes
+* mintty, as of version of 2.7.6, requires `RowSpacing=-1` in the `.minttyrc` file for the box drawing glyphs not to be invisible.
+ * This is found in `$HOME/.minttyrc` for `Cygwin` use, or
+ * `%LOCALAPPDATA%\wsltty\home\%USERNAME%\.minttyrc` for `wsltty` use
+ * Through Git bisect, I found that this commit causes the breakage, although I'm not sure if it is a bug or feature. https://github.com/mintty/mintty/commit/2cc746667595e08f57b12cfa0df0b67787762620
+
+## Introduction
+I love romeovs's creep font, but I think you could only use it well in Apple's Terminal.app
+because it has negative line and character width spacing, which the font requires to be spaced correctly.
+The root cause of this appears to be because some glyphs are bigger than the 5px by 11px bounding box,
+causing most terminals to think a much bigger box is necessary for the general ASCII glyphs.
+
+In order to fix this issue, I manually hand painted all the glyphs from the 'creep' font in fontforge.
+This was probably not the smartest way, but I did not feel like researching a way to import it by code.
+On the plus side, I was watching a few movies while drawing these glyphs, so it wasn't too bad ;-)
+
+After doing this I could understand why some characters extend past the bounding box, as 5x11 is ridiculously small
+for the more complicated glyphs. However, to get it to work nicely on terminals and editors without negative spacing support,
+I had to use my best judgement and truncate or modify certain glpyhs so they all fit without exceptions. This of course
+is not as nice, and arguably makes certain glyphs much less recognizable, but I felt it was an acceptable compromise since
+they do not appear often.
+
+### Result
+
+By maintaining the strict 5x11 bounding box, I was able to get the font working in all the programs I typically use that don't support fancy spacing adjustment:
+* XTerm (BDF format)
+* UXRvt (BDF format)
+* X11 (BDF format)
+* Windows GVim (TTF with embedded bitmaps)
+* mintty (TTF with embedded bitmap, add "LineSpacing=-1" to config file to get 11px per row height, add "LineSpacing=0" for newer builds (Apr 8 2016)).
+* Notepad.exe (TTF with embedded bitmaps)
+
+Now I have crazy awesome code density :-)
+
+## Original Here:
+### https://github.com/romeovs/creep
diff --git a/creep2.ttf b/creep2.ttf
new file mode 100755
index 000000000000..0de1e764ef2e
--- /dev/null
+++ b/creep2.ttf
Binary files differ