summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblacktemplar2018-03-24 15:26:16 +0100
committerblacktemplar2018-03-24 15:26:16 +0100
commitdc9e5e2eb97ade07a5964fb7afbd13dd31425846 (patch)
treec3ca136901655754ec2c7f7e1f15a991487f637b
downloadaur-creeptd.tar.gz
first creeptd package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e794bb8d7f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = creeptd
+ pkgdesc = CreepTD is a multiplayer tower defense game
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = http://www.creeptd.com
+ arch = any
+ license = custom
+ depends = java-runtime
+ source = http://www.creeptd.com/download/creeptd-linux.tar.gz
+ sha256sums = 5ecd7cedbba4f5a61bfd4c1a22eb519129e49498f85fa7d028c2074b48f740eb
+
+pkgname = creeptd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d19732c53d8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: blacktemplar <blacktemplar@a1.net>
+pkgname=('creeptd')
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="CreepTD is a multiplayer tower defense game"
+arch=('any')
+url="http://www.creeptd.com"
+license=('custom')
+depends=('java-runtime')
+source=("http://www.creeptd.com/download/$pkgname-linux.tar.gz")
+sha256sums=('5ecd7cedbba4f5a61bfd4c1a22eb519129e49498f85fa7d028c2074b48f740eb')
+
+package() {
+ cd CreepTD
+
+ # license file
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # program directory
+ mkdir -p "$pkgdir/opt/"
+ cp -r . "$pkgdir/opt/$pkgname"
+
+ # allow all users to access directories (self updating application)
+ chmod -R 777 "$pkgdir/opt/$pkgname"
+
+ # desktop file
+ cp CreepTD.desktop CreepTD.desktop.template
+ sed -i "s/.\/CreepTD/\/opt\/$pkgname\/CreepTD/g" CreepTD.desktop.template
+ install -Dm644 CreepTD.desktop.template "$pkgdir/usr/share/applications/CreepTD.desktop"
+}