summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Picht2019-06-29 13:30:56 +0200
committerMichael Picht2019-06-29 13:30:56 +0200
commit464f8054433e27f0ac582bfc9874748e70224f9e (patch)
treecd7582dfbdd5a0ee665013e6e21db38048467a27
parent2a1fadac15b0c14bf536162bcffb105f1cbda300 (diff)
downloadaur-464f8054433e27f0ac582bfc9874748e70224f9e.tar.gz
Release 1.4
-rw-r--r--[l---------]PKGBUILD24
1 files changed, 23 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fe62689d304f..83995beb3295 120000..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1 +1,23 @@
-../../crema/pkg/PKGBUILD \ No newline at end of file
+# Maintainer: Michael Picht <mipi@fsfe.org>
+
+_pkgorg=github.com/mipimipi
+pkgname=crema-git
+_pkgname=crema
+pkgver=1.4
+pkgrel=1
+pkgdesc="Manage your custom Arch Linux repositories"
+arch=('any')
+url="https://$_pkgorg/$_pkgname"
+license=('GPL3')
+source=("git://$_pkgorg/$_pkgname.git")
+md5sums=(SKIP)
+depends=('aurutils' 'devtools' 'rsync')
+optdepends=('gnupg')
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 -t "$pkgdir/usr/bin/" "$_pkgname"
+}