summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Picht2020-01-02 08:03:29 +0000
committerMichael Picht2020-01-02 08:03:29 +0000
commit5d78d71f6533dcc64cf99d0e01c19ed4ce313fa3 (patch)
tree8a8547b486efd809fa973e025b96e955584f58de
parent1bd93947331cb6a36b38a5c362073f5ced8aee93 (diff)
downloadaur-5d78d71f6533dcc64cf99d0e01c19ed4ce313fa3.tar.gz
pipeline: added git config
Signed-off-by: Michael Picht <mipi@fsfe.org>
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD69
2 files changed, 75 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c16d70bc3e6..0d459be11df6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,30 @@
pkgbase = crema-git
- pkgdesc = Manage your custom Arch Linux repositories
- pkgver = 1.4
+ pkgdesc = Manage custom (remote) repositories
+ pkgver = 2.0
pkgrel = 1
- url = https://github.com/mipimipi/crema
+ url = https://gitlab.com/mipimipi/crema
arch = any
license = GPL3
makedepends = git
- depends = aurutils
+ makedepends = make
+ makedepends = pandoc
+ depends = binutils
depends = devtools
depends = rsync
+ depends = jq
+ depends = pacutils
+ depends = parallel
+ depends = wget
optdepends = gnupg
- source = git://github.com/mipimipi/crema.git
+ optdepends = bash-completion: bash completion
+ optdepends = devtools: aur-chroot
+ optdepends = vifm: build file interaction
+ provides = crema
+ conflicts = crema
+ conflicts = aurutils
+ conflicts = aurutils-git
+ source = git+https://gitlab.com/mipimipi/crema.git
+ validpgpkeys = 11ECD6695134183B3E7AF1C2223AAA374A1D59CE
md5sums = SKIP
pkgname = crema-git
diff --git a/PKGBUILD b/PKGBUILD
index 408069d84aed..2ec02b56ae82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,67 @@
# Maintainer: Michael Picht <mipi@fsfe.org>
-_pkgorg=github.com/mipimipi
+_pkgorg=gitlab.com/mipimipi
pkgname=crema-git
_pkgname=crema
-pkgver=1.4
+pkgver=2.0
pkgrel=1
-pkgdesc="Manage your custom Arch Linux repositories"
-arch=('any')
+pkgdesc="Manage custom (remote) repositories"
+arch=(any)
url="https://$_pkgorg/$_pkgname"
-license=('GPL3')
-source=("git://$_pkgorg/$_pkgname.git")
+license=(GPL3)
+source=("git+https://$_pkgorg/$_pkgname.git")
+validpgpkeys=(11ECD6695134183B3E7AF1C2223AAA374A1D59CE) # Michael Picht <mipi@fsfe.org>
md5sums=(SKIP)
-depends=('aurutils' 'devtools' 'rsync')
-makedepends=('git')
-optdepends=('gnupg')
+depends=(
+ binutils
+ devtools
+ rsync
+)
+makedepends=(
+ git
+ make
+ pandoc
+)
+optdepends=(gnupg)
+provides=(crema)
+conflicts=(crema)
+
+# aurutils
+conflicts+=(
+ aurutils
+ aurutils-git
+)
+depends+=(
+ jq
+ pacutils
+ parallel
+ wget
+)
+optdepends+=(
+ "bash-completion: bash completion"
+ "devtools: aur-chroot"
+ "vifm: build file interaction"
+)
+
pkgver() {
- cd "$srcdir/$_pkgname"
- printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$_pkgname"
+ git -C "${_pkgname}" describe --long --tags | sed "s/-/.r/;s/-/./g"
}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make
+
+ # aurutils
+ cd aurutils
+ make DESTDIR="$pkgdir"
+}
+
package() {
- cd "$srcdir/$_pkgname"
- install -Dm755 -t "$pkgdir/usr/bin/" "$_pkgname"
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir" install
+
+ # aurutils
+ cd aurutils
+ make DESTDIR="$pkgdir" install
}