summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenton Liu2020-12-31 15:02:54 -0800
committerDenton Liu2020-12-31 15:02:54 -0800
commita3abdd949cbe914a6e95a54674784859c8624d7c (patch)
treef26efa2e9f12659b7796403c0741a621737e4233
parent1304c0e70de9e99b4b129b015b62ca4f562e94a2 (diff)
downloadaur-a3abdd949cbe914a6e95a54674784859c8624d7c.tar.gz
PKGBUILD: use version without -linux suffix
With the `-linux` suffix, CrewLink would detect this as an incompatible version and refuse to run. Use the version without the suffix so that this does not happen.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6b9d32be33f..ba390f0894f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = crewlink
pkgdesc = Free, open, Among Us Proximity Chat
pkgver = 1.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/zbanks/CrewLink
arch = x86_64
license = GPL3
makedepends = yarn
optdepends = sudo: crewlink-launcher support
- source = https://github.com/zbanks/CrewLink/archive/v1.2.1-linux.tar.gz
+ source = https://github.com/zbanks/CrewLink/archive/v1.2.1.tar.gz
source = crewlink-launcher
- sha256sums = 4d7d77c6d2bb473e3d9e6c24fb98462d29321ff4ca4a8472875d3f43608e760f
+ sha256sums = d3734df31d4e203f37f6fce0aeb2ab1303ee8b5435cd57ce56fd1362f6560cb6
sha256sums = 264849ad57fab753f9991399c39dbfb07e8996e0440b6f77d6e3470e38f71de6
pkgname = crewlink
diff --git a/PKGBUILD b/PKGBUILD
index b81647be63d4..86a6b35507e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Denton Liu <liu.denton@gmail.com>
pkgname=crewlink
pkgver=1.2.1
-pkgrel=1
+pkgrel=2
pkgdesc='Free, open, Among Us Proximity Chat'
arch=('x86_64')
url='https://github.com/zbanks/CrewLink'
license=('GPL3')
makedepends=('yarn')
optdepends=('sudo: crewlink-launcher support')
-source=("https://github.com/zbanks/CrewLink/archive/v$pkgver-linux.tar.gz"
+source=("https://github.com/zbanks/CrewLink/archive/v$pkgver.tar.gz"
crewlink-launcher)
-sha256sums=('4d7d77c6d2bb473e3d9e6c24fb98462d29321ff4ca4a8472875d3f43608e760f'
+sha256sums=('d3734df31d4e203f37f6fce0aeb2ab1303ee8b5435cd57ce56fd1362f6560cb6'
'264849ad57fab753f9991399c39dbfb07e8996e0440b6f77d6e3470e38f71de6')
build() {
- cd "$srcdir/CrewLink-$pkgver-linux"
+ cd "$srcdir/CrewLink-$pkgver"
yarn install
yarn dist-linux
}
@@ -23,7 +23,7 @@ package() {
cd "$srcdir"
mkdir -p "$pkgdir/opt"
- cp -r "CrewLink-$pkgver-linux/dist/linux-unpacked" "$pkgdir/opt/CrewLink"
+ cp -r "CrewLink-$pkgver/dist/linux-unpacked" "$pkgdir/opt/CrewLink"
mkdir -p "$pkgdir/usr/bin"
ln -s /opt/CrewLink/crewlink "$pkgdir/usr/bin/crewlink"