summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2020-10-30 12:07:40 +0100
committerDavid Runge2020-10-30 12:07:40 +0100
commit166c90b284dfffc93deebd3108e273d962c0d046 (patch)
tree5c091e4dae602f6de2fc11616f7260ca55a9e815
parent88277c0e0aa6dba6a6c135de77402674700f6f24 (diff)
downloadaur-166c90b284dfffc93deebd3108e273d962c0d046.tar.gz
Rebuild to fix default paths and depends
PKGBUILD: Add cni-plugins, conmon, conntrack-tools and runc to depends. Remove cni-plugins and conmon from otpdepends (they are now in depends and cri-o is too disfunctional without them). Add container-runtime to provides. Ensure the use of /run over /var/run in prepare(). Ensure to set the correct path for cni-plugins.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
2 files changed, 22 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50bfacd003c7..f1d204853c34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cri-o
pkgdesc = Open Container Initiative-based implementation of Kubernetes Container Runtime Interface
pkgver = 1.19.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cri-o/cri-o
arch = x86_64
license = Apache
@@ -10,9 +10,12 @@ pkgbase = cri-o
makedepends = go-md2man
makedepends = libseccomp
makedepends = ostree
+ depends = cni-plugins
+ depends = conmon
+ depends = conntrack-tools
depends = glibc
- optdepends = cni-plugins: for CNI networking
- optdepends = conmon: for per-container monitoring
+ depends = runc
+ provides = container-runtime
options = emptydirs
backup = etc/crio/crio.conf
source = cri-o-1.19.0.tar.gz::https://github.com/cri-o/cri-o/archive/v1.19.0.tar.gz
@@ -23,7 +26,11 @@ pkgbase = cri-o
b2sums = 8d77c8060f483c943bd48d9bc2c1d676878e570b29989b7ff733906612b6dff09ed1ffcabc5174175ebc667df897e37e98a8132016bddcb27137661fca2da6dd
pkgname = cri-o
+ depends = cni-plugins
+ depends = conmon
+ depends = conntrack-tools
depends = glibc
+ depends = runc
depends = libgpgme.so
depends = libseccomp.so
diff --git a/PKGBUILD b/PKGBUILD
index 9c28085ac65b..5644b051159c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,14 @@
pkgname=cri-o
pkgver=1.19.0
-pkgrel=1
+pkgrel=2
pkgdesc="Open Container Initiative-based implementation of Kubernetes Container Runtime Interface"
arch=('x86_64')
url="https://github.com/cri-o/cri-o"
license=('Apache')
-depends=('glibc')
+depends=('cni-plugins' 'conmon' 'conntrack-tools' 'glibc' 'runc')
makedepends=('gpgme' 'go' 'go-md2man' 'libseccomp' 'ostree')
-optdepends=('cni-plugins: for CNI networking'
- 'conmon: for per-container monitoring')
+provides=('container-runtime')
backup=('etc/crio/crio.conf')
# configuration override and hook directories should exist
options=('emptydirs')
@@ -24,9 +23,18 @@ b2sums=('8288985392a08fb7fdc58f509d34f8814bf9670386b7aae42be349765cb1f3bd3f4b770
prepare() {
cd "${pkgname}-${pkgver}"
+ # make sure that /run instead of /var/run is used
+ sed -e 's|/var/run|/run|g' \
+ -i crictl.yaml pkg/config/config{,_unix}.go \
+ docs/*.md crio-umount.conf \
+ vendor/github.com/containers/conmon/runner/config/config_unix.go \
+ vendor/github.com/containers/storage/{storage.conf,store.go}
# make sure that /usr/bin is used in systemd units
sed -e 's|/usr/local|/usr|g' \
-i contrib/systemd/*.service
+ # set the correct default PATH for cni-plugins
+ sed -e 's|/opt/cni/bin/|/usr/lib/cni/|g' \
+ -i pkg/config/config_unix.go
# do not statically link pinns and enable PIE
patch -Np1 -i "../${pkgname}-1.19.0-pinns_pie.patch"
}