summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorЕловский Валентин Владимирович2018-07-14 18:56:34 +0700
committerЕловский Валентин Владимирович2018-07-14 18:56:34 +0700
commit07ffb0f379567f520d1f665445ecd47493ab7ee1 (patch)
tree0960aa264b5f2717a28f4dd517f27a071fbc0ba9
downloadaur-07ffb0f379567f520d1f665445ecd47493ab7ee1.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
-rw-r--r--crictl.yaml4
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45867c7c09b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = crictl-bin
+ pkgdesc = CLI tool for Kubelet Container Runtime Interface (CRI)
+ pkgver = 1.11.1
+ pkgrel = 1
+ url = https://github.com/eulerto/wal2json
+ arch = x86_64
+ license = Apache
+ source = https://github.com/kubernetes-incubator/cri-tools/releases/download/v1.11.1/crictl-v1.11.1-linux-amd64.tar.gz
+ source = crictl.yaml
+ sha256sums = ccf83574556793ceb01717dc91c66b70f183c60c2bbec70283939aae8fdef768
+ sha256sums = d2725490e1fb2e6f565605f09871c1440371b85e04de5d70bbac05954d827f72
+
+pkgname = crictl-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b871e711b59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: ProFfeSsoRr <evvsoft at gmail dot com>
+
+pkgname=crictl-bin
+pkgver=1.11.1
+pkgrel=1
+pkgdesc="CLI tool for Kubelet Container Runtime Interface (CRI)"
+arch=(x86_64)
+url="https://github.com/eulerto/wal2json"
+license=('Apache')
+source=("https://github.com/kubernetes-incubator/cri-tools/releases/download/v${pkgver}/crictl-v${pkgver}-linux-amd64.tar.gz"
+ "crictl.yaml")
+sha256sums=('ccf83574556793ceb01717dc91c66b70f183c60c2bbec70283939aae8fdef768'
+ 'd2725490e1fb2e6f565605f09871c1440371b85e04de5d70bbac05954d827f72')
+
+package() {
+ cd "$srcdir"
+ install -Dm755 crictl "$pkgdir"/usr/bin/crictl
+ install -Dm644 crictl.yaml "$pkgdir"/etc/crictl.yaml
+}
+
diff --git a/crictl.yaml b/crictl.yaml
new file mode 100644
index 000000000000..ddaa475b9172
--- /dev/null
+++ b/crictl.yaml
@@ -0,0 +1,4 @@
+runtime-endpoint: unix:///run/containerd/containerd.sock
+image-endpoint: unix:///run/containerd/containerd.sock
+timeout: 10
+debug: false