summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWinston Weinert2017-04-02 22:29:35 -0500
committerWinston Weinert2017-04-02 22:34:17 -0500
commit382f0e9fb1abc1b7fb5f58481d9be846f1f9b3ad (patch)
treebd6fd36e792af7135eb063982c3b6fbc5cd5d7b7
downloadaur-382f0e9fb1abc1b7fb5f58481d9be846f1f9b3ad.tar.gz
Create pkgbuild for crimson
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD37
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93fd535f631d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = crimson
+ pkgdesc = Crimson Fields is a turn-based tactical war game. It can be played against a human opponent in hot-seat mode in front of the same machine, over a network, or via e-mail, or against the computer.
+ pkgver = 0.5.3
+ pkgrel = 1
+ url = http://crimson.seul.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = sdl
+ depends = sdl_ttf
+ depends = sdl_mixer
+ depends = sdl_net
+ source = http://crimson.seul.org/files/crimson-0.5.3.tar.gz
+ sha512sums = 56a0c8c3e271f6ca53baaee23c28b594033b2d3e4b22fb4cd58c9858dc2bda556a13d1204cdba607da0a4414affb455b1403dde73e385a1accdd5162ec9e0a89
+
+pkgname = crimson
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0d7a3296cb2d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+# From https://gist.github.com/PaBLoX-CL/6479725 (kudos!)
+
+# ignore everything
+*
+!.gitignore
+
+# except PKGBUILD needed files
+!PKGBUILD
+!*.install
+!ChangeLog
+!.SRCINFO
+
+# common wing-man files
+!*.diff
+!*.patch
+
+# add files that don't have an online source
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e837dd061b84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Winston Weinert <winston@ml1.net>
+
+pkgname=crimson
+pkgver=0.5.3
+pkgrel=1
+epoch=
+pkgdesc='Crimson Fields is a turn-based tactical war game. It can be played against a human opponent in hot-seat mode in front of the same machine, over a network, or via e-mail, or against the computer.'
+arch=('i686' 'x86_64')
+url="http://crimson.seul.org"
+license=('GPL')
+depends=('sdl'
+ 'sdl_ttf'
+ 'sdl_mixer'
+ 'sdl_net')
+source=("$url/files/$pkgname-$pkgver.tar.gz")
+sha512sums=('56a0c8c3e271f6ca53baaee23c28b594033b2d3e4b22fb4cd58c9858dc2bda556a13d1204cdba607da0a4414affb455b1403dde73e385a1accdd5162ec9e0a89')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: