summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2020-08-26 23:58:37 -0700
committerMike Swanson2020-08-26 23:58:37 -0700
commit016a0c6c9de0321795e4e53df9469cdd1553c818 (patch)
tree0acdf69e5a352641643f79d71ee2e87ce2ea0a3b
parent492d31b531dae98c4c4eedf4f178999f0ea6eea0 (diff)
downloadaur-016a0c6c9de0321795e4e53df9469cdd1553c818.tar.gz
Backport a fix for SIGIL's default file name
Crispy tries to be too clever to force its way around file name casing, and failed on the case of someone using SIGIL’s default file name.
-rw-r--r--.SRCINFO4
-rw-r--r--0001-consider-Sigil-s-mixed-case-file-names.patch34
-rw-r--r--PKGBUILD8
3 files changed, 42 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1a9c44e0775..447f29406dfc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = crispy-doom
pkgdesc = Vanilla-compatible enhanced Doom engine
pkgver = 5.9.0
- pkgrel = 1
+ pkgrel = 2
url = http://fabiangreffrath.github.io/crispy-doom
install = crispy-doom.install
arch = i686
@@ -17,7 +17,9 @@ pkgbase = crispy-doom
optdepends = freedoom1: Free Ultimate Doom-compatible game
optdepends = freedoom2: Free Doom II-compatible game
source = https://github.com/fabiangreffrath/crispy-doom/archive/crispy-doom-5.9.0.tar.gz
+ source = 0001-consider-Sigil-s-mixed-case-file-names.patch
b2sums = a97bb7d9bda0c4e984054a0051cadfcaba7c758829bec9e615801bbf91dc1c8063decfedf5b76056cd2fb05e8fcf4113f19c10d72604399b715011d994af3e8b
+ b2sums = 0b4fa985b47924e770f8f750c8f4835c374fb689c86ef2324578835d9a8659cc32390029af73e9ac494e383750fbfaa23ceae1e81f6f87fc9f75739083cca3d6
pkgname = crispy-doom
diff --git a/0001-consider-Sigil-s-mixed-case-file-names.patch b/0001-consider-Sigil-s-mixed-case-file-names.patch
new file mode 100644
index 000000000000..74f39e1fae36
--- /dev/null
+++ b/0001-consider-Sigil-s-mixed-case-file-names.patch
@@ -0,0 +1,34 @@
+From 7b30ea0a2d70b2e17b929f8af0eefbc54016a42c Mon Sep 17 00:00:00 2001
+From: Fabian Greffrath <fabian@greffrath.com>
+Date: Thu, 27 Aug 2020 08:06:21 +0200
+Subject: [PATCH] consider Sigil's mixed case file names
+
+We already try some common cases when trying to find and load
+a WAD file, but never the mixed case that the Sigil WADs come
+with by default.
+
+Hopefully fixes #655, thanks @kitchen-ace and @kbterkelsen.
+---
+ src/doom/d_pwad.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/doom/d_pwad.c b/src/doom/d_pwad.c
+index e0be6a22..8a659c77 100644
+--- a/src/doom/d_pwad.c
++++ b/src/doom/d_pwad.c
+@@ -36,9 +36,9 @@ void D_LoadSigilWad (void)
+ char *dirname;
+
+ const char *const sigil_wads[] = {
+- "SIGIL_V1_21.WAD",
+- "SIGIL_V1_2.WAD",
+- "SIGIL.WAD"
++ "SIGIL_v1_21.wad",
++ "SIGIL_v1_2.wad",
++ "SIGIL.wad"
+ };
+
+ struct {
+--
+2.28.0
+
diff --git a/PKGBUILD b/PKGBUILD
index a65ce617f256..7303311f5746 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=crispy-doom
pkgdesc="Vanilla-compatible enhanced Doom engine"
pkgver=5.9.0
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="http://fabiangreffrath.github.io/crispy-doom"
license=('GPL2')
@@ -13,8 +13,10 @@ optdepends=('freedm: Free deathmatch game'
'freedoom1: Free Ultimate Doom-compatible game'
'freedoom2: Free Doom II-compatible game')
install=crispy-doom.install
-source=(https://github.com/fabiangreffrath/$pkgname/archive/$pkgname-$pkgver.tar.gz)
-b2sums=('a97bb7d9bda0c4e984054a0051cadfcaba7c758829bec9e615801bbf91dc1c8063decfedf5b76056cd2fb05e8fcf4113f19c10d72604399b715011d994af3e8b')
+source=(https://github.com/fabiangreffrath/$pkgname/archive/$pkgname-$pkgver.tar.gz
+ 0001-consider-Sigil-s-mixed-case-file-names.patch)
+b2sums=('a97bb7d9bda0c4e984054a0051cadfcaba7c758829bec9e615801bbf91dc1c8063decfedf5b76056cd2fb05e8fcf4113f19c10d72604399b715011d994af3e8b'
+ '0b4fa985b47924e770f8f750c8f4835c374fb689c86ef2324578835d9a8659cc32390029af73e9ac494e383750fbfaa23ceae1e81f6f87fc9f75739083cca3d6')
prepare() {
cd "$pkgname-$pkgname-$pkgver"