summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2020-09-04 21:41:22 -0700
committerMike Swanson2020-09-04 21:41:22 -0700
commitc7000bf022464f8a858b6365fe4dfa48b09f58be (patch)
treebb2c1e868b13b42d919fa99505647ac7734b12b4
parent016a0c6c9de0321795e4e53df9469cdd1553c818 (diff)
downloadaur-c7000bf022464f8a858b6365fe4dfa48b09f58be.tar.gz
Update to 5.9.1
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Only-load-Sigil-when-gameversion-is-Ultimate-Doom-66.patch28
-rw-r--r--0001-consider-Sigil-s-mixed-case-file-names.patch34
-rw-r--r--PKGBUILD10
4 files changed, 39 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 447f29406dfc..4e13ff283f16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = crispy-doom
pkgdesc = Vanilla-compatible enhanced Doom engine
- pkgver = 5.9.0
- pkgrel = 2
+ pkgver = 5.9.1
+ pkgrel = 1
url = http://fabiangreffrath.github.io/crispy-doom
install = crispy-doom.install
arch = i686
@@ -16,10 +16,10 @@ pkgbase = crispy-doom
optdepends = freedm: Free deathmatch game
optdepends = freedoom1: Free Ultimate Doom-compatible game
optdepends = freedoom2: Free Doom II-compatible game
- source = https://github.com/fabiangreffrath/crispy-doom/archive/crispy-doom-5.9.0.tar.gz
- source = 0001-consider-Sigil-s-mixed-case-file-names.patch
- b2sums = a97bb7d9bda0c4e984054a0051cadfcaba7c758829bec9e615801bbf91dc1c8063decfedf5b76056cd2fb05e8fcf4113f19c10d72604399b715011d994af3e8b
- b2sums = 0b4fa985b47924e770f8f750c8f4835c374fb689c86ef2324578835d9a8659cc32390029af73e9ac494e383750fbfaa23ceae1e81f6f87fc9f75739083cca3d6
+ source = https://github.com/fabiangreffrath/crispy-doom/archive/crispy-doom-5.9.1.tar.gz
+ source = 0001-Only-load-Sigil-when-gameversion-is-Ultimate-Doom-66.patch
+ b2sums = 2bf862d8134689afba101abeed5cf1e1695378f235718941bf9fc2717bc93dd848173bb758e8bf0bc4a8ab1bfa75533c2ae838210326451f7c4285b0acb2e08b
+ b2sums = e6566c793fc561c0beb350e0ce075580b7374b2f18764ff61b960e7410c1f4b79300bbf37050891c1fe38e98ec706d2bc696a8e0700b55cf13eb8517901339c9
pkgname = crispy-doom
diff --git a/0001-Only-load-Sigil-when-gameversion-is-Ultimate-Doom-66.patch b/0001-Only-load-Sigil-when-gameversion-is-Ultimate-Doom-66.patch
new file mode 100644
index 000000000000..077f9a81557e
--- /dev/null
+++ b/0001-Only-load-Sigil-when-gameversion-is-Ultimate-Doom-66.patch
@@ -0,0 +1,28 @@
+From 5690872369e59ad106add2573eed748cf0e9f741 Mon Sep 17 00:00:00 2001
+From: kitchen-ace <47063032+kitchen-ace@users.noreply.github.com>
+Date: Fri, 4 Sep 2020 16:56:23 -0400
+Subject: [PATCH] Only load Sigil when gameversion is Ultimate Doom (#661)
+
+Fixes errors caused by Sigil being loaded playing Chex Quest.
+
+Co-authored-by: kitchen-ace <68k@quikphix.org>
+---
+ src/doom/d_main.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/doom/d_main.c b/src/doom/d_main.c
+index b89631f5..7571cfbb 100644
+--- a/src/doom/d_main.c
++++ b/src/doom/d_main.c
+@@ -1852,7 +1852,7 @@ void D_DoomMain (void)
+ // [crispy] allow overriding of special-casing
+ if (!M_ParmExists("-noautoload") && gamemode != shareware)
+ {
+- if (gamemode == retail)
++ if (gamemode == retail && gameversion == exe_ultimate)
+ {
+ D_LoadSigilWad();
+ }
+--
+2.28.0
+
diff --git a/0001-consider-Sigil-s-mixed-case-file-names.patch b/0001-consider-Sigil-s-mixed-case-file-names.patch
deleted file mode 100644
index 74f39e1fae36..000000000000
--- a/0001-consider-Sigil-s-mixed-case-file-names.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 7b30ea0a2d70b2e17b929f8af0eefbc54016a42c Mon Sep 17 00:00:00 2001
-From: Fabian Greffrath <fabian@greffrath.com>
-Date: Thu, 27 Aug 2020 08:06:21 +0200
-Subject: [PATCH] consider Sigil's mixed case file names
-
-We already try some common cases when trying to find and load
-a WAD file, but never the mixed case that the Sigil WADs come
-with by default.
-
-Hopefully fixes #655, thanks @kitchen-ace and @kbterkelsen.
----
- src/doom/d_pwad.c | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/doom/d_pwad.c b/src/doom/d_pwad.c
-index e0be6a22..8a659c77 100644
---- a/src/doom/d_pwad.c
-+++ b/src/doom/d_pwad.c
-@@ -36,9 +36,9 @@ void D_LoadSigilWad (void)
- char *dirname;
-
- const char *const sigil_wads[] = {
-- "SIGIL_V1_21.WAD",
-- "SIGIL_V1_2.WAD",
-- "SIGIL.WAD"
-+ "SIGIL_v1_21.wad",
-+ "SIGIL_v1_2.wad",
-+ "SIGIL.wad"
- };
-
- struct {
---
-2.28.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 7303311f5746..431499406e67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=crispy-doom
pkgdesc="Vanilla-compatible enhanced Doom engine"
-pkgver=5.9.0
-pkgrel=2
+pkgver=5.9.1
+pkgrel=1
arch=('i686' 'x86_64')
url="http://fabiangreffrath.github.io/crispy-doom"
license=('GPL2')
@@ -14,9 +14,9 @@ optdepends=('freedm: Free deathmatch game'
'freedoom2: Free Doom II-compatible game')
install=crispy-doom.install
source=(https://github.com/fabiangreffrath/$pkgname/archive/$pkgname-$pkgver.tar.gz
- 0001-consider-Sigil-s-mixed-case-file-names.patch)
-b2sums=('a97bb7d9bda0c4e984054a0051cadfcaba7c758829bec9e615801bbf91dc1c8063decfedf5b76056cd2fb05e8fcf4113f19c10d72604399b715011d994af3e8b'
- '0b4fa985b47924e770f8f750c8f4835c374fb689c86ef2324578835d9a8659cc32390029af73e9ac494e383750fbfaa23ceae1e81f6f87fc9f75739083cca3d6')
+ 0001-Only-load-Sigil-when-gameversion-is-Ultimate-Doom-66.patch)
+b2sums=('2bf862d8134689afba101abeed5cf1e1695378f235718941bf9fc2717bc93dd848173bb758e8bf0bc4a8ab1bfa75533c2ae838210326451f7c4285b0acb2e08b'
+ 'e6566c793fc561c0beb350e0ce075580b7374b2f18764ff61b960e7410c1f4b79300bbf37050891c1fe38e98ec706d2bc696a8e0700b55cf13eb8517901339c9')
prepare() {
cd "$pkgname-$pkgname-$pkgver"