summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Bachmann2017-09-03 16:02:57 +0200
committerSimon Bachmann2017-09-03 16:02:57 +0200
commitaad06b905f76809c1f9f4b23fd9f01e54d8b4994 (patch)
treeaaffc9cc8095870f0d8beedc616a48e780f00c4f
parentd9840adc93c5250c1d2c59807c80d347109b435a (diff)
downloadaur-critcl-git.tar.gz
Removed 'destdir.patch'. Problem has been fixed upstream
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--destdir.patch58
3 files changed, 7 insertions, 73 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e0acc76e6c9..800a34fad0a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = critcl-git
pkgdesc = Critcl lets you easily embed C code in Tcl.
pkgver = 3.1.16rc0.r10.21a4e10
- pkgrel = 2
+ pkgrel = 3
url = http://andreas-kupries.github.io/critcl/
arch = any
license = BSD
@@ -13,9 +13,7 @@ pkgbase = critcl-git
provides = critcl
conflicts = critcl
source = critcl::git+http://github.com/andreas-kupries/critcl#branch=master
- source = destdir.patch
md5sums = SKIP
- md5sums = b7d96a2d75916544babf9b7c160eeeff
-
+
pkgname = critcl-git
diff --git a/PKGBUILD b/PKGBUILD
index 57728ce2c500..91431e8fb8e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Simon Bachmann simonbachmann@bluewin.ch
-pkgname=critcl-git # '-bzr', '-git', '-hg' or '-svn'
-pkgver=3.1.16rc0.r10.21a4e10
-pkgrel=2
+pkgname=critcl-git
+pkgver=3.1.17.r3.ed54049
+pkgrel=3
pkgdesc="Critcl lets you easily embed C code in Tcl."
arch=('any')
url="http://andreas-kupries.github.io/critcl/"
@@ -15,10 +15,9 @@ replaces=()
backup=()
options=()
install=
-source=('critcl::git+http://github.com/andreas-kupries/critcl#branch=master' 'destdir.patch')
+source=('critcl::git+http://github.com/andreas-kupries/critcl#branch=master')
noextract=()
-md5sums=('SKIP'
- 'b7d96a2d75916544babf9b7c160eeeff')
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -28,11 +27,6 @@ pkgver() {
}
-prepare() {
- cd "$srcdir/${pkgname%-git}"
- patch -p1 -i "$srcdir/destdir.patch"
-}
-
build() {
cd "$srcdir/${pkgname%-git}"
# Only thing to build is the doc
diff --git a/destdir.patch b/destdir.patch
deleted file mode 100644
index d654a8ff0c47..000000000000
--- a/destdir.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-diff -ur andreas-kupries-critcl-62a03a2/build.tcl andreas-kupries-critcl-62a03a2-mod/build.tcl
---- andreas-kupries-critcl-62a03a2/build.tcl 2016-11-03 08:36:34.000000000 +0100
-+++ andreas-kupries-critcl-62a03a2-mod/build.tcl 2017-01-28 11:31:04.251417238 +0100
-@@ -1,7 +1,7 @@
- #!/bin/sh
- # -*- tcl -*- \
- exec tclsh "$0" ${1+"$@"}
--package require Tcl 8.4
-+package require Tcl 8.5
- unset -nocomplain ::errorInfo
- set me [file normalize [info script]]
- proc main {} {
-@@ -105,6 +105,24 @@
- }
- return $path
- }
-+proc dstlfromlib {path} {
-+ # kinda the inverse of findlib above
-+ # returns the path to dstlpath, relative the */lib path returned by findlib
-+ # The path is returned
-+ # as a list of directories
-+ set relpath {}
-+ while {1} {
-+ if {[file tail $path] eq "lib"} {
-+ break
-+ }
-+ set new [file dirname $path]
-+ set relpath [list [file tail $path] {*}$relpath]
-+ if {$new eq $path} break
-+ set path $new
-+ }
-+ return $relpath
-+}
-+
- proc id {cv vv} {
- upvar 1 $cv commit $vv version
-
-@@ -366,9 +384,17 @@
- # Application: critcl
-
- set theapp [critapp $dsta]
--
-- set c [open $theapp w]
-- puts $c "#!/bin/sh\n# -*- tcl -*- \\\nexec [file dirname [file normalize [info nameofexecutable]/___]] \"\$0\" \$\{1+\"\$@\"\}\npackage require critcl::app\ncritcl::app::main \$argv"
-+ set reldstl [dstlfromlib $dstl]
-+
-+ set c [open $theapp w]
-+ puts $c {#!/bin/sh}
-+ puts $c "# -*- tcl -*- \\"
-+ puts $c "exec [file dirname [file normalize [info nameofexecutable]/___]] \"\$0\" \$\{1+\"\$@\"\}\n"
-+ puts $c {set libpath [file normalize [file join [file dirname [info script]] .. lib]]}
-+ puts $c "set libpath \[file join \$libpath $reldstl \]"
-+ puts $c {if {$libpath ni $auto_path} {lappend auto_path $libpath}}
-+ puts $c "\npackage require critcl::app"
-+ puts $c "critcl::app::main \$argv"
- close $c
- +x $theapp
-