summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsashok7242022-04-06 02:32:12 +0300
committersashok7242022-04-06 02:32:12 +0300
commit535c8e2e25686ccf3a70d4cda593100c9f4f6015 (patch)
treedfc920338ecd3ebed7f98f51dd331b320bf69f82
parent8bb51c67717b4158c46a292b51c99c3a1513b192 (diff)
downloadaur-criu-git.tar.gz
Made PKGBUILD consistent with repo package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 26 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dfb5f0eb8ac..b85feef83884 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = criu-git
- pkgdesc = A Checkpoint/Restore functionality for Linux in Userspace, git version
- pkgver = r10517.38012e535
+ pkgdesc = Utilities to checkpoint and restore processes in userspace, git version
+ pkgver = r10915.5b2e5855c
pkgrel = 1
url = https://github.com/checkpoint-restore/criu
arch = x86_64
@@ -8,16 +8,18 @@ pkgbase = criu-git
makedepends = xmlto
makedepends = asciidoc
makedepends = git
- depends = protobuf-c
- depends = libnl
+ depends = libbsd
depends = libnet
- depends = python
+ depends = libnl
+ depends = protobuf-c
depends = python-protobuf
+ depends = gnutls
+ depends = nftables
provides = criu
conflicts = criu
options = !buildflags
+ options = !lto
source = git+https://github.com/checkpoint-restore/criu
sha256sums = SKIP
pkgname = criu-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 2a6c57aa4dad..413235915ad6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
+# Maintainer: sashok724 <archlinux at sashok724 dot net>
+# Contributor: George Rawlinson <grawlinson@archlinux.org>
# Contributor: aksr <aksr at t-com dot me>
# Contributor: Pavel Borzenkov <pavel@voidptr.ru>
-# Maintainer: sashok724 <archlinux at sashok724 dot net>
_pkgname=criu
pkgname=criu-git
-pkgver=r10517.38012e535
+pkgver=r10915.5b2e5855c
pkgrel=1
-pkgdesc="A Checkpoint/Restore functionality for Linux in Userspace, git version"
-arch=('x86_64')
+pkgdesc="Utilities to checkpoint and restore processes in userspace, git version"
url='https://github.com/checkpoint-restore/criu'
license=('GPL2')
+arch=('x86_64')
provides=('criu')
conflicts=('criu')
-depends=('protobuf-c' 'libnl' 'libnet' 'python' 'python-protobuf')
-makedepends=('xmlto' 'asciidoc' 'git')
source=("git+$url")
-sha256sums=('SKIP')
-options=('!buildflags')
+depends=('libbsd' 'libnet' 'libnl' 'protobuf-c' 'python-protobuf' 'gnutls' 'nftables')
+makedepends=('xmlto' 'asciidoc' 'git')
+options=('!buildflags' '!lto')
+sha256sums=(SKIP)
pkgver() {
cd $_pkgname
@@ -30,9 +31,13 @@ build() {
package() {
cd "$srcdir/$_pkgname"
- make DESTDIR="$pkgdir/" \
- PREFIX=/usr \
- SBINDIR=/usr/bin \
- LOGROTATEDIR=/etc/logrotate.d \
- LIBDIR=/usr/lib install
+ make DESTDIR="$pkgdir" \
+ PREFIX=/usr \
+ SBINDIR=/usr/bin \
+ LIBDIR=/usr/lib \
+ LIBEXECDIR=/usr/lib \
+ install
+
+ # remove empty directory
+ rmdir "$pkgdir/usr/include/compel/common/asm"
}