summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2016-12-07 08:28:33 -0700
committerBrian Bidulock2016-12-07 08:28:33 -0700
commitf79bd52ec18b90f9a176eb517e766b66c3dc8c43 (patch)
tree87135c8c935f2ed74dd895ccaa741d96e8642a9c
downloadaur-f79bd52ec18b90f9a176eb517e766b66c3dc8c43.tar.gz
initial version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..956ff2d2e177
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = crmsh
+ pkgdesc = Command-line interface for high-availability cluster management on GNU/Linux systems
+ pkgver = 2.2.1
+ pkgrel = 1
+ url = https://github.com/ClusterLabs/crmsh/
+ arch = any
+ license = GPL2
+ makedepends = asciidoc
+ depends = python
+ depends = gawk
+ source = crmsh-2.2.1.tar.gz::https://github.com/ClusterLabs/crmsh/archive/2.2.1.tar.gz
+ md5sums = 81f8e4595fa53f9f220a7500e3759e6c
+
+pkgname = crmsh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d64f4f5d37d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+
+pkgname=crmsh
+pkgver=2.2.1
+pkgrel=1
+pkgdesc="Command-line interface for high-availability cluster management on GNU/Linux systems"
+arch=('any')
+url="https://github.com/ClusterLabs/${pkgname}/"
+license=('GPL2')
+makedepends=('asciidoc')
+depends=('python' 'gawk')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ClusterLabs/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('81f8e4595fa53f9f220a7500e3759e6c')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ ./autogen.sh
+}
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr \
+ --libdir=/usr/lib \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --localstatedir=/var
+ make V=0
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: set sw=2 et:
+