summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2017-05-18 06:57:08 -0600
committerBrian Bidulock2017-05-18 06:57:08 -0600
commit9a0d71ccc5900ef9b9d0a51e56824ccf51099308 (patch)
treeb1171c65bb678ca8d7b53a81fc0701ffe7f193c4
parent7ef862a0b0587824980bca7e07614de4a031a9de (diff)
downloadaur-9a0d71ccc5900ef9b9d0a51e56824ccf51099308.tar.gz
build with python2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1a15e0b287f..966f7c41855a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = crmsh-git
pkgdesc = Command-line interface for high-availability cluster management on GNU/Linux systems
pkgver = 3.0.0.r22.g19533ef4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ClusterLabs/crmsh/
arch = any
license = GPL2
makedepends = git
makedepends = asciidoc
- depends = python
+ depends = python2
depends = gawk
provides = crmsh
conflicts = crmsh
diff --git a/PKGBUILD b/PKGBUILD
index 9e5e8431e5d5..139eccf785b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=crmsh-git
_pkgname=crmsh
pkgver=3.0.0.r22.g19533ef4
-pkgrel=1
+pkgrel=2
pkgdesc="Command-line interface for high-availability cluster management on GNU/Linux systems"
arch=('any')
url="https://github.com/ClusterLabs/${_pkgname}/"
license=('GPL2')
makedepends=('git' 'asciidoc')
-depends=('python' 'gawk')
+depends=('python2' 'gawk')
provides=(${_pkgname})
conflicts=(${_pkgname})
source=("$pkgname::git+https://github.com/ClusterLabs/${_pkgname}.git")
@@ -27,7 +27,8 @@ prepare() {
build() {
cd ${pkgname}
- ./configure --prefix=/usr \
+ ./configure PYTHON=python2 \
+ --prefix=/usr \
--libdir=/usr/lib \
--sbindir=/usr/bin \
--sysconfdir=/etc \