summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-06-29 00:06:35 +0000
committerGeorge Rawlinson2022-06-29 00:06:35 +0000
commitba20d280b145584a915e22b923571aed4558f4fb (patch)
tree75fdb8dbebb2be6d8d142c24a3d248db514fb59e
downloadaur-ba20d280b145584a915e22b923571aed4558f4fb.tar.gz
addpkg: cro-mag-rally 3.0.0-1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD76
-rw-r--r--cro-mag-rally.desktop11
-rwxr-xr-xcro-mag-rally.sh4
4 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d99339ec9979
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = cro-mag-rally
+ pkgdesc = The wildest racing game since man invented the wheel!
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://github.com/jorio/CroMagRally
+ arch = x86_64
+ license = custom:CC-BY-NC-SA-4.0
+ makedepends = cmake
+ makedepends = git
+ depends = sdl2
+ depends = glu
+ depends = hicolor-icon-theme
+ source = cro-mag-rally::git+https://github.com/jorio/CroMagRally.git#commit=b05c1428a5c25c0bef7d4c6fe9323d14780e82f2
+ source = git+https://github.com/jorio/Pomme.git
+ source = cro-mag-rally.desktop
+ source = cro-mag-rally.sh
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = 2395a1f207c58e1ffdfe9a6036b99ad7ea3a19f6ab7a0418ed7c256f8c32ccfedf69924bfa3af807dfb7db33457d237d55f5b89566fc1ba87e182d701947eca9
+ b2sums = ca267b6b8f9a0d1a8202bd938abbfe641ca1d8dbcf6d645bc311303a5fa407096648e4abb18c39c8324b8174295840daef67dea82e39866d3a7d89f06edb9a3c
+
+pkgname = cro-mag-rally
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..971f7924ff1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# Maintainer: George Rawlinson <george@rawlinson.net.nz>
+
+pkgname=cro-mag-rally
+pkgver=3.0.0
+pkgrel=1
+pkgdesc='The wildest racing game since man invented the wheel!'
+arch=('x86_64')
+url='https://github.com/jorio/CroMagRally'
+license=('custom:CC-BY-NC-SA-4.0')
+depends=('sdl2' 'glu' 'hicolor-icon-theme')
+makedepends=('cmake' 'git')
+_commit='b05c1428a5c25c0bef7d4c6fe9323d14780e82f2'
+source=(
+ "$pkgname::git+$url.git#commit=$_commit"
+ 'git+https://github.com/jorio/Pomme.git'
+ "$pkgname.desktop"
+ "$pkgname.sh"
+)
+b2sums=('SKIP'
+ 'SKIP'
+ '2395a1f207c58e1ffdfe9a6036b99ad7ea3a19f6ab7a0418ed7c256f8c32ccfedf69924bfa3af807dfb7db33457d237d55f5b89566fc1ba87e182d701947eca9'
+ 'ca267b6b8f9a0d1a8202bd938abbfe641ca1d8dbcf6d645bc311303a5fa407096648e4abb18c39c8324b8174295840daef67dea82e39866d3a7d89f06edb9a3c')
+
+pkgver() {
+ cd "$pkgname"
+
+ git describe --tags | sed 's/^v//'
+}
+
+prepare() {
+ cd "$pkgname"
+
+ # handle git submodules
+ git submodule init
+ git config submodule.extern/Pomme.url ../Pomme
+ git submodule update
+}
+
+build() {
+ cd "$pkgname"
+
+ cmake -S . -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -Wno-dev
+
+ cmake --build build
+}
+
+package() {
+ cd "$pkgname"
+
+ # move binary & assets
+ install -vd "$pkgdir/usr/lib/$pkgname"
+ #mv -v build/{Data,Bugdom} "$pkgdir/usr/lib/$pkgname"
+ install -vDm755 -t "$pkgdir/usr/lib/$pkgname" build/CroMagRally
+ mv -v build/Data "$pkgdir/usr/lib/$pkgname"
+
+ # wrapper script for $PATH execution
+ install -vDm755 "$srcdir/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+
+ # desktop file & icon
+ install -vDm644 -t "$pkgdir/usr/share/applications" "$srcdir/$pkgname.desktop"
+ install -vDm644 packaging/cromagrally-desktopicon.png \
+ "$pkgdir/usr/share/icons/hicolor/512x512/apps/$pkgname.png"
+
+ # documentation
+ install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" *.md
+ rm -vf "$pkgdir/usr/share/doc/$pkgname/LICENSE.md"
+ cp -vr docs "$pkgdir/usr/share/doc/$pkgname"
+ sed -e "s/@PROJECT_VERSION@/$pkgver/" packaging/ReadMe.txt.in \
+ > "$pkgdir/usr/share/doc/$pkgname/README"
+
+ # license
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE.md
+}
diff --git a/cro-mag-rally.desktop b/cro-mag-rally.desktop
new file mode 100644
index 000000000000..b34e7ea56709
--- /dev/null
+++ b/cro-mag-rally.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Cro-Mag Rally
+Comment=The wildest racing game since man invented the wheel!
+Icon=cro-mag-rally
+Exec=/usr/lib/cro-mag-rally/CroMagRally
+Path=/usr/lib/cro-mag-rally
+Terminal=false
+Categories=Game;
+Encoding=UTF-8
diff --git a/cro-mag-rally.sh b/cro-mag-rally.sh
new file mode 100755
index 000000000000..67fba14543ce
--- /dev/null
+++ b/cro-mag-rally.sh
@@ -0,0 +1,4 @@
+#!/usr/bin/sh
+
+cd /usr/lib/cro-mag-rally
+exec /usr/lib/cro-mag-rally/CroMagRally