aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiacoLenzo21092021-02-25 22:51:58 +0100
committerGiacoLenzo21092021-02-25 22:51:58 +0100
commit4dc692811bcebbe1ae2284000be4cbea0ae3ae00 (patch)
tree2db8e552972379a6569d12b15af3875bc7e6abd3
downloadaur-4dc692811bcebbe1ae2284000be4cbea0ae3ae00.tar.gz
Upload
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD68
-rw-r--r--README.md3
-rw-r--r--croco-common-settings.install56
4 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10bfdb87d1f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = croco-common-settings-git
+ pkgver = r40.187953a
+ pkgrel = 1
+ url = https://gitlab.com/croco-os/themes-and-settings/settings/croco-common-settings
+ arch = any
+ license = GPL
+ makedepends = git
+ source = git+https://gitlab.com/croco-os/themes-and-settings/settings/croco-common-settings.git#branch=master
+ sha256sums = SKIP
+
+pkgname = croco-common-settings-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4332e1c57144
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: GiacoLenzo2109 <GiacoLenzo2109@gmail.com>
+# Contributor: Librewish <librewish@gmail.com>
+
+pkgbase=croco-common-settings-git
+_gitname=croco-common-settings-git
+pkgname=(
+ 'croco-common-settings-git'
+ )
+pkgver=r40.187953a
+pkgrel=1
+arch=('any')
+_branch='master'
+url="https://gitlab.com/croco-os/themes-and-settings/settings/croco-common-settings"
+license=('GPL')
+makedepends=('git')
+source=("git+$url.git#branch=${_branch}")
+sha256sums=('SKIP')
+
+_install() {
+ if [[ -d $srcdir/$_gitname/$1/etc ]]; then
+ install -d $pkgdir/etc
+ cp -rf $srcdir/$_gitname/$1/etc $pkgdir
+ fi
+
+ if [[ -d $srcdir/$_gitname/$1/usr ]]; then
+ install -d $pkgdir/etc
+ cp -rf $srcdir/$_gitname/$1/usr $pkgdir
+ fi
+
+ if [[ -d $srcdir/$_gitname/$1/skel ]]; then
+ install -d $pkgdir/etc
+ cp -rf $srcdir/$_gitname/$1/skel $pkgdir/etc
+ fi
+
+}
+
+pkgver() {
+ cd "$srcdir/croco-common-settings"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+package_croco-common-settings() {
+ pkgdesc='Croco OS Linux common settings'
+ depends=(
+ 'croco-icons'
+ #'croco-browser-settings'
+ 'croco-hooks'
+ 'haveged'
+ 'irqbalance'
+ 'systemd-swap'
+ 'nohang-git'
+ 'prelockd-git'
+ 'memavaild-git'
+ 'ananicy-git'
+ 'profile-sync-daemon'
+ 'preload'
+ )
+ optdepends=(
+ 'performance-tweaks'
+ )
+ install=croco-common-settings.install
+
+ _install ''
+}
+
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..9e3c73579f23
--- /dev/null
+++ b/README.md
@@ -0,0 +1,3 @@
+# croco-common-settings
+
+PKGBUILD for croco-common-settings
diff --git a/croco-common-settings.install b/croco-common-settings.install
new file mode 100644
index 000000000000..ac615811b15a
--- /dev/null
+++ b/croco-common-settings.install
@@ -0,0 +1,56 @@
+msg() {
+ ALL_OFF="\e[1;0m"
+ BOLD="\e[1;1m"
+ GREEN="${BOLD}\e[1;32m"
+ local mesg=$1; shift
+ printf "${GREEN}==>${ALL_OFF}${BOLD} ${mesg}${ALL_OFF}" "$@" >&2
+}
+
+post_install() {
+ systemctl enable haveged
+ systemctl enable systemd-swap
+ systemctl enable irqbalance
+ systemctl enable nohang-desktop
+ systemctl enable memavaild
+ systemctl enable prelockd
+ systemctl enable ananicy
+ systemctl enable grub-btrfs.path
+ systemctl enable fstrim.timer
+ systemctl enable btrfs-scrub@-.timer
+ systemctl enable preload
+}
+
+post_upgrade() {
+ msg "Attempting to enable services..."
+ systemctl is-active haveged >/dev/null || systemctl enable haveged
+ systemctl is-active systemd-swap >/dev/null || systemctl enable systemd-swap
+ systemctl is-active irqbalance >/dev/null || systemctl enable irqbalance
+ systemctl is-active nohang-desktop >/dev/null || systemctl enable nohang-desktop
+ systemctl is-active memavaild >/dev/null || systemctl enable memavaild
+ systemctl is-active prelockd >/dev/null || systemctl enable prelockd
+ systemctl is-active ananicy >/dev/null || systemctl enable ananicy
+ systemctl is-active grub-btrfs.path >/dev/null || systemctl enable grub-btrfs.path
+ systemctl is-active fstrim.timer >/dev/null || systemctl enable fstrim.timer
+ systemctl is-active btrfs-scrub@-.timer >/dev/null || systemctl enable btrfs-scrub@-.timer
+ systemctl is-active preload >/dev/null || systemctl enable preload
+ echo ""
+ msg "services should now be enabled."
+ echo ""
+ echo -n "Updating font cache... "
+ echo ""
+ mkfontscale /usr/share/fonts/TTF /usr/share/fonts/OTF /usr/share/fonts/misc > /dev/null 2>&1
+ mkfontdir /usr/share/fonts/TTF /usr/share/fonts/OTF /usr/share/fonts/misc > /dev/null 2>&1
+ fc-cache -s >/dev/null
+ echo ""
+ echo "done"
+ echo ""
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+ /bin/sh -c 'dconf update'
+ echo ""
+ chmod 750 /etc/sudoers.d
+ echo "Permissions fixed."
+ echo ""
+}
+
+# vim: ts=2 sw=2 et: