aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiacoLenzo21092021-02-25 15:56:38 +0100
committerGiacoLenzo21092021-02-25 15:56:38 +0100
commitd814996186b8c3dc6b75ebec5fccb73cb2e3c22d (patch)
treed0bf51ee3bf7fcb8d1c42daf7f05b311c00c28e3
downloadaur-croco-gnome-settings.tar.gz
Upload
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD60
-rw-r--r--README.md3
-rw-r--r--croco-gnome-settings.install24
4 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64e34049b1a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = croco-gnome-settings
+ pkgver = r77.94ad064
+ pkgrel = 1
+ url = https://gitlab.com/croco-os/themes-and-settings/settings/croco-gnome-settings
+ arch = any
+ license = GPL
+ makedepends = git
+ source = git+https://gitlab.com/croco-os/themes-and-settings/settings/croco-gnome-settings.git#branch=master
+ sha256sums = SKIP
+
+pkgname = croco-gnome-settings
+ pkgdesc = Croco OS GNOME settings
+ install = croco-gnome-settings.install
+ depends = croco-common-settings
+ depends = kvantum-qt5
+ depends = nerd-fonts-fantasque-sans-mono
+ depends = qt5ct
+ depends = yaru-sound-theme
+ provides = croco-desktop-settings
+ conflicts = croco-desktop-settings
+ conflicts = sweet-theme-dark
+ conflicts = sweet-theme-git
+ conflicts = kvantum-theme-sweet-git
+ conflicts = xcursor-sweet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b29639381f99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: GiacoLenzo2109 <GiacoLenzo2109@gmail.com>
+# Contributor: Librewish <librewish@gmail.com>
+
+pkgbase=croco-gnome-settings
+_gitname=croco-gnome-settings
+pkgname=(
+ 'croco-gnome-settings'
+ )
+pkgver=r77.94ad064
+pkgrel=1
+arch=('any')
+_branch='master'
+url="https://gitlab.com/croco-os/themes-and-settings/settings/croco-gnome-settings"
+license=('GPL')
+makedepends=('git')
+source=("git+$url.git#branch=${_branch}")
+sha256sums=('SKIP')
+
+_install() {
+ if [[ -d $srcdir/$_gitname/$1/etc ]]; then
+ install -d $pkgdir/etc
+ cp -rf $srcdir/$_gitname/$1/etc $pkgdir
+ fi
+
+ if [[ -d $srcdir/$_gitname/$1/usr ]]; then
+ install -d $pkgdir/etc
+ cp -rf $srcdir/$_gitname/$1/usr $pkgdir
+ fi
+
+ if [[ -d $srcdir/$_gitname/$1/skel ]]; then
+ install -d $pkgdir/etc
+ cp -rf $srcdir/$_gitname/$1/skel $pkgdir/etc
+ fi
+
+}
+
+pkgver() {
+ cd "$srcdir/croco-gnome-settings"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+package_croco-gnome-settings() {
+ pkgdesc='Croco OS GNOME settings'
+ depends=(
+ 'croco-common-settings'
+ 'kvantum-qt5'
+ 'nerd-fonts-fantasque-sans-mono'
+ 'qt5ct'
+ 'yaru-sound-theme'
+ )
+
+ install=croco-gnome-settings.install
+ provides=('croco-desktop-settings')
+ conflicts=('croco-desktop-settings' 'sweet-theme-dark' 'sweet-theme-git' 'kvantum-theme-sweet-git' 'xcursor-sweet')
+
+ _install ''
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..a0992a7576bd
--- /dev/null
+++ b/README.md
@@ -0,0 +1,3 @@
+# croco-gnome-settings
+
+PKGBUILD for croco-gnome-settings
diff --git a/croco-gnome-settings.install b/croco-gnome-settings.install
new file mode 100644
index 000000000000..a0cefd4a246b
--- /dev/null
+++ b/croco-gnome-settings.install
@@ -0,0 +1,24 @@
+msg() {
+ ALL_OFF="\e[1;0m"
+ BOLD="\e[1;1m"
+ GREEN="${BOLD}\e[1;32m"
+ local mesg=$1; shift
+ printf "${GREEN}==>${ALL_OFF}${BOLD} ${mesg}${ALL_OFF}" "$@" >&2
+}
+
+post_install() {
+post_upgrade
+}
+
+post_upgrade() {
+ echo -n "Updating font cache... "
+ mkfontscale /usr/share/fonts/TTF /usr/share/fonts/OTF /usr/share/fonts/misc > /dev/null 2>&1
+ mkfontdir /usr/share/fonts/TTF /usr/share/fonts/OTF /usr/share/fonts/misc > /dev/null 2>&1
+ fc-cache -s >/dev/null
+ echo "Done."
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+ /bin/sh -c 'dconf update'
+}
+
+# vim: ts=2 sw=2 et: