aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiacoLenzo21092021-02-25 16:07:57 +0100
committerGiacoLenzo21092021-02-25 16:07:57 +0100
commit220bde5443f34857a4e5573be6a236695310a4dc (patch)
tree40123304e9aa6a837915e77a156dd0c195856452
downloadaur-croco-tools-git.tar.gz
Upload
-rw-r--r--.SRCINFO60
-rw-r--r--PKGBUILD93
-rw-r--r--README.md3
-rw-r--r--croco-32.patch70
4 files changed, 226 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a43d0e77e9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,60 @@
+pkgbase = croco-tools-git
+ pkgdesc = Development tools for croco Linux
+ pkgver = r18.38b258e
+ pkgrel = 1
+ url = https://gitlab.com/croco-os/tools/croco-tools
+ arch = x86_64
+ arch = i686
+ groups = croco-tools
+ license = GPL
+ makedepends = git
+ makedepends = docbook2x
+ source = croco-tools::git+https://gitlab.com/croco-os/tools/croco-tools.git#branch=master
+ sha256sums = SKIP
+
+pkgname = croco-tools-base-git
+ pkgdesc = Development tools for croco Linux (base tools)
+ depends = openssh
+ depends = rsync
+ depends = haveged
+ depends = os-prober
+ depends = gnupg
+ depends = pacman-mirrorlist>=20160301
+ optdepends = croco-tools-pkg: croco Linux package tools
+ optdepends = croco-tools-iso: croco Linux iso tools
+ optdepends = croco-tools-yaml: croco Linux yaml tools
+ provides = croco-tools-base=0.15.6
+ conflicts = croco-tools-base
+ backup = etc/croco-tools/croco-tools.conf
+
+pkgname = croco-tools-pkg-git
+ pkgdesc = Development tools for croco Linux (packaging tools)
+ depends = namcap
+ depends = croco-tools-base-git
+ provides = croco-tools-pkg=0.15.6
+ conflicts = croco-tools-pkg
+ conflicts = devtools
+
+pkgname = croco-tools-iso-git
+ pkgdesc = Development tools for croco Linux (ISO tools)
+ depends = dosfstools
+ depends = libisoburn
+ depends = squashfs-tools
+ depends = croco-tools-yaml-git
+ depends = mkinitcpio
+ depends = mktorrent
+ depends = grub
+ depends = git
+ optdepends = virtualbox: quickly test isos
+ optdepends = snapd: for snapd support
+ provides = croco-tools-iso=0.15.6
+ conflicts = croco-tools-iso
+
+pkgname = croco-tools-yaml-git
+ pkgdesc = Development tools for croco Linux (yaml tools)
+ depends = croco-tools-base-git
+ depends = calamares-tools
+ depends = ruby-kwalify
+ provides = croco-tools-yaml=0.15.6
+ conflicts = croco-tools-yaml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a42390145f0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,93 @@
+# Maintainer: GiacoLenzo2109 <GiacoLenzo2109@gmail.com>
+# Contributor: Philip Müller <philm@garuda.org>
+# Contributor: Bernhard Landauer <oberon@garuda.org>
+# Contributor: Frede Hundewadt <fhatgarudarg>
+
+_pkgbase=croco-tools
+_ver=0.15.6
+#_branch=stable-0.15.x
+_branch=master
+
+pkgbase=croco-tools-git
+pkgname=('croco-tools-base-git'
+ 'croco-tools-pkg-git'
+ 'croco-tools-iso-git'
+ 'croco-tools-yaml-git')
+pkgver=r18.38b258e
+pkgrel=1
+arch=('x86_64' 'i686')
+pkgdesc='Development tools for croco Linux'
+license=('GPL')
+groups=('croco-tools')
+url='https://gitlab.com/croco-os/tools/croco-tools'
+makedepends=('git' 'docbook2x')
+source=("croco-tools::git+$url.git#branch=$_branch")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${srcdir}/${_pkgbase}
+ # patches here
+ sed -e "s/^Version=.*/Version=$_ver/" -i Makefile
+ #sed -e "s/^Version=.*/Version=$pkgver/" -i Makefile
+ if [ "${CARCH}" = "i686" ]; then
+ patch -p2 -i ${srcdir}/croco-32.patch
+ fi
+}
+
+pkgver() {
+ cd ${srcdir}/${_pkgbase}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${srcdir}/${_pkgbase}
+ make SYSCONFDIR=/etc PREFIX=/usr
+}
+
+package_croco-tools-base-git() {
+ pkgdesc='Development tools for croco Linux (base tools)'
+ provides=("croco-tools-base=$_ver")
+ depends=('openssh' 'rsync' 'haveged' 'os-prober' 'gnupg' 'pacman-mirrorlist>=20160301')
+ optdepends=('croco-tools-pkg: croco Linux package tools'
+ 'croco-tools-iso: croco Linux iso tools'
+ 'croco-tools-yaml: croco Linux yaml tools')
+ conflicts=('croco-tools-base')
+ backup=('etc/croco-tools/croco-tools.conf')
+
+ cd ${srcdir}/${_pkgbase}
+ make SYSCONFDIR=/etc PREFIX=/usr DESTDIR=${pkgdir} install_base
+}
+
+package_croco-tools-pkg-git() {
+ pkgdesc='Development tools for croco Linux (packaging tools)'
+ provides=("croco-tools-pkg=$_ver")
+ depends=('namcap' 'croco-tools-base-git')
+ conflicts=('croco-tools-pkg' 'devtools')
+
+ cd ${srcdir}/${_pkgbase}
+ make SYSCONFDIR=/etc PREFIX=/usr DESTDIR=${pkgdir} install_pkg
+}
+
+package_croco-tools-yaml-git() {
+ pkgdesc='Development tools for croco Linux (yaml tools)'
+ provides=("croco-tools-yaml=$_ver")
+ conflicts=('croco-tools-yaml')
+ depends=('croco-tools-base-git' 'calamares-tools' 'ruby-kwalify')
+
+ cd ${srcdir}/${_pkgbase}
+ make SYSCONFDIR=/etc PREFIX=/usr DESTDIR=${pkgdir} install_yaml
+}
+
+package_croco-tools-iso-git() {
+ pkgdesc='Development tools for croco Linux (ISO tools)'
+ provides=("croco-tools-iso=$_ver")
+ depends=('dosfstools' 'libisoburn' 'squashfs-tools' 'croco-tools-yaml-git'
+ 'mkinitcpio' 'mktorrent' 'grub' 'git')
+ conflicts=('croco-tools-iso')
+ optdepends=('virtualbox: quickly test isos'
+ 'snapd: for snapd support')
+
+ cd ${srcdir}/${_pkgbase}
+ make SYSCONFDIR=/etc PREFIX=/usr DESTDIR=${pkgdir} install_iso
+}
+
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..4fac25530cfe
--- /dev/null
+++ b/README.md
@@ -0,0 +1,3 @@
+# croco-tools-git
+
+PKGBUILD for croco-tools-git
diff --git a/croco-32.patch b/croco-32.patch
new file mode 100644
index 000000000000..188e32078886
--- /dev/null
+++ b/croco-32.patch
@@ -0,0 +1,70 @@
+--- a/croco-tools/lib/util.sh 2017-11-01 14:15:59.293276152 -0400
++++ b/croco-tools/lib/util.sh 2017-12-31 12:45:22.599475136 -0500
+@@ -66,7 +66,7 @@ get_pac_mirrors_conf(){
+ local conf="$tmp_dir/pacman-mirrors-$1.conf"
+ cp "${DATADIR}/pacman-mirrors.conf" "$conf"
+ sed -i "$conf" \
+- -e "s|Branch = stable|Branch = $1|"
++ -e "s|Branch = x32-stable|Branch = $1|"
+
+ echo "$conf"
+ }
+@@ -201,7 +201,7 @@ set_branch(){
+ }
+
+ init_common(){
+- [[ -z ${target_branch} ]] && target_branch='stable'
++ [[ -z ${target_branch} ]] && target_branch='x32-stable'
+
+ [[ -z ${target_arch} ]] && target_arch=$(uname -m)
+
+@@ -749,7 +749,7 @@ is_valid_arch_iso(){
+
+ is_valid_branch(){
+ case $1 in
+- 'stable'|'testing'|'unstable') return 0 ;;
++ 'x32-stable'|'x32-testing'|'x32-unstable') return 0 ;;
+ *) return 1 ;;
+ esac
+ }
+--- a/croco-tools/lib/util-iso.sh 2017-11-01 14:15:59.269942128 -0400
++++ b/croco-tools/lib/util-iso.sh 2017-12-31 12:58:11.425522151 -0500
+@@ -221,7 +221,7 @@ gen_iso_fn(){
+ fi
+ [[ ${initsys} == 'openrc' ]] && vars+=("${initsys}")
+ vars+=("${dist_release}")
+- vars+=("${target_branch}")
++ vars+=("${target_branch/x32-/}")
+ vars+=("${target_arch}")
+ for n in ${vars[@]};do
+ name=${name:-}${name:+-}${n}
+diff --git a/croco-tools/data/pacman-mirrors.conf b/croco-tools/data/pacman-mirrors.conf
+index 7141548..e33e526 100644
+--- a/croco-tools/data/pacman-mirrors.conf
++++ b/croco-tools/data/pacman-mirrors.conf
+@@ -2,8 +2,8 @@
+ ## /etc/pacman-mirrors.conf
+ ##
+
+-## Branch Pacman should use (stable, testing, unstable)
+-Branch = stable
++## Branch Pacman should use (x32-stable, x32-testing, x32-unstable)
++Branch = x32-stable
+
+ ## Generation method
+ ## 1) rank - rank mirrors depending on their access time
+
+diff --git a/croco-tools/data/croco-tools.conf b/croco-tools/data/croco-tools.conf
+index 52f5866..05b20d1 100644
+--- a/croco-tools/data/croco-tools.conf
++++ b/croco-tools/data/croco-tools.conf
+@@ -3,7 +3,7 @@
+ ######################################################
+
+ # default target branch
+-# target_branch=stable
++# target_branch=x32-stable
+
+ # default taget arch: auto detect
+ # target_arch=$(uname -m)
+