aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiacoLenzo21092021-02-25 16:09:50 +0100
committerGiacoLenzo21092021-02-25 16:09:50 +0100
commitc577a7f1804ea9f1bb23cbab40b32837bd5f2826 (patch)
tree75501a748b645ec72c9fb38a334c8eadfc04ebfe
downloadaur-croco-welcome-git.tar.gz
Upload
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD33
-rw-r--r--README.md3
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fa0f66cde20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = croco-welcome-git
+ pkgdesc = A Welcome app for Croco OS
+ pkgver = r81.785bb36
+ pkgrel = 1
+ url = https://gitlab.com/croco-os/applications/croco-welcome
+ arch = any
+ groups = croco-git
+ license = GPL3
+ makedepends = git
+ depends = qt5-base
+ depends = xdg-utils
+ optdepends = xorg-xrandr
+ optdepends = xorg-xinput
+ optdepends = croco-assistant
+ optdepends = croco-network-assistant
+ optdepends = qwikaccess
+ optdepends = croco-gamer
+ optdepends = croco-boot-options
+ provides = croco-welcome
+ conflicts = croco-welcome
+ source = repo::git+https://gitlab.com/croco-os/applications/croco-welcome.git
+ md5sums = SKIP
+
+pkgname = croco-welcome-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ba807d072e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+_pkgname=croco-welcome
+pkgname=${_pkgname}-git
+pkgver=r81.785bb36
+pkgrel=1
+pkgdesc="A Welcome app for Croco OS"
+arch=('any')
+url="https://gitlab.com/croco-os/applications/croco-welcome"
+license=('GPL3')
+depends=('qt5-base' 'xdg-utils')
+optdepends=( 'xorg-xrandr' 'xorg-xinput' 'croco-assistant' 'croco-network-assistant' 'qwikaccess' 'croco-gamer' 'croco-boot-options')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+groups=('croco-git')
+source=("repo::git+https://gitlab.com/croco-os/applications/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/repo"
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/repo"
+ qmake-qt5 ${_pkgname}.pro
+ make
+}
+
+package() {
+ cd "$srcdir/repo"
+ make INSTALL_ROOT=${pkgdir} install
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..701604d531d9
--- /dev/null
+++ b/README.md
@@ -0,0 +1,3 @@
+# croco-welcome-git
+
+PKGBUILD for croco-welcome-git