summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-27 10:18:16 +0100
committerAlexander F. Rødseth2019-03-27 10:18:16 +0100
commitdf02d4fc726d3fbb24b26aa46a32d339f8203e9e (patch)
tree8e5d9bc7b20c271a3fb1a175edd13a6367d4233e
downloadaur-df02d4fc726d3fbb24b26aa46a32d339f8203e9e.tar.gz
Move from [community] to AUR in connection with the spring cleaning
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
-rw-r--r--make-generic.patch25
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..775a7b1d27d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Mar 27 09:15:57 UTC 2019
+pkgbase = cromfs
+ pkgdesc = Compressed read-only filesystem based on FUSE
+ pkgver = 1.5.10.2
+ pkgrel = 3
+ url = http://bisqwit.iki.fi/source/cromfs.html
+ arch = x86_64
+ license = GPL
+ depends = fuse2
+ depends = lzo
+ depends = gcc-libs
+ options = !makeflags
+ source = http://bisqwit.iki.fi/src/arch/cromfs-1.5.10.2.tar.gz
+ source = make-generic.patch
+ sha256sums = 26d513eb14f3c75939e49ad9e212556a9580af3ac82640dffd64d32b6b654def
+ sha256sums = 92dc71c3830583abf600c20afce6edf3ad933aeb6f60d5417d04e5376654d5fc
+
+pkgname = cromfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5b85b85a65c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer:
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=cromfs
+pkgver=1.5.10.2
+pkgrel=3
+arch=('x86_64')
+pkgdesc='Compressed read-only filesystem based on FUSE'
+url='http://bisqwit.iki.fi/source/cromfs.html'
+license=('GPL')
+depends=('fuse2' 'lzo' 'gcc-libs')
+options=('!makeflags')
+source=("http://bisqwit.iki.fi/src/arch/${pkgname}-${pkgver}.tar.gz"
+ 'make-generic.patch')
+sha256sums=('26d513eb14f3c75939e49ad9e212556a9580af3ac82640dffd64d32b6b654def'
+ '92dc71c3830583abf600c20afce6edf3ad933aeb6f60d5417d04e5376654d5fc')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 -i ../make-generic.patch
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -d "${pkgdir}"/usr/{bin,share/doc/cromfs}
+ install -m755 install/progs/* "${pkgdir}"/usr/bin/
+ install -m644 install/docs/* "${pkgdir}"/usr/share/doc/cromfs/
+}
diff --git a/make-generic.patch b/make-generic.patch
new file mode 100644
index 000000000000..6dff65efbf1d
--- /dev/null
+++ b/make-generic.patch
@@ -0,0 +1,25 @@
+diff -Naur old/configure new/configure
+--- old/configure 2012-04-11 09:33:55.000000000 +0200
++++ new/configure 2012-04-11 12:05:07.098916602 +0200
+@@ -96,9 +96,9 @@
+ fi
+ }
+
+-CFLAGS=""
+-CPPFLAGS=""
+-LDFLAGS=""
++CFLAGS="$CFLAGS"
++CPPFLAGS="$CXXFLAGS"
++LDFLAGS="$LDFLAGS"
+ OPTIM=""
+
+ do_echo -n "Determining compiler version to use... "
+@@ -451,6 +451,8 @@
+ OPTIM="$OPTIM_BACKUP $BEST_CPUFEATURE"
+ fi
+
++OPTIM=""
++
+ do_echo "Updating Makefile.sets ..."
+
+ if [ "$DEBUG" = "1" ]; then