summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvangelos Foutras2014-04-10 09:12:57 +0000
committerEvangelos Foutras2014-04-10 09:12:57 +0000
commit656f73d4459b9aebe83e14fae37c67b71536df01 (patch)
treeabf448d12ced2f4abdda206512401e2bf8792a35
parenta2ddf195a32ef00a08dbefc643873c3abe92e768 (diff)
downloadaur-656f73d4459b9aebe83e14fae37c67b71536df01.tar.gz
New upstream release.
-rw-r--r--PKGBUILD37
-rw-r--r--chromium-depot-tools-r0.patch11
-rw-r--r--chromium-gn-r1.patch (renamed from chromium-gn-r0.patch)9
3 files changed, 37 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9cc3b480e17c..937ddd397014 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=chromium
-pkgver=33.0.1750.152
-_toolchains_rev=12526
-pkgrel=2
+pkgver=34.0.1847.116
+_toolchains_rev=12773
+pkgrel=1
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
arch=('i686' 'x86_64')
url="http://www.chromium.org/"
license=('BSD')
-depends=('gtk2' 'nss' 'alsa-lib' 'xdg-utils' 'bzip2' 'libevent' 'libxss' 'icu'
+depends=('gtk2' 'nss' 'alsa-lib' 'xdg-utils' 'bzip2' 'libevent' 'libxss'
'libgcrypt' 'ttf-font' 'systemd' 'dbus' 'flac' 'opus' 'snappy'
'speech-dispatcher' 'pciutils' 'libpulse' 'harfbuzz' 'harfbuzz-icu'
'desktop-file-utils' 'hicolor-icon-theme')
@@ -32,19 +32,21 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
naclsdk_pnacl_translator-$_toolchains_rev.tgz.sha1hash::https://commondatastorage.googleapis.com/nativeclient-archive2/toolchain/$_toolchains_rev/naclsdk_pnacl_translator.tgz.sha1hash
chromium.desktop
chromium.default
- chromium-gn-r0.patch
+ chromium-gn-r1.patch
+ chromium-depot-tools-r0.patch
chromium.sh)
noextract=(naclsdk_nacl_linux_x86-$_toolchains_rev.tgz
naclsdk_pnacl_linux_x86-$_toolchains_rev.tgz
naclsdk_pnacl_translator-$_toolchains_rev.tgz)
-sha256sums=('9fd462840bee3ae205b0548e8a483f7589beecdb7c6309d4d65425cbf710cc2f'
- '4bc956815bd45a82ed7c3b623d0ffb55fcc6c6af55828a0bf1560733def68e8d'
- '3ae77302adf775f2d513e7d9cb730cbe3e42d515002c4388d25fa3ec11b7b12f'
- 'ce89d9c53b32a83f477e9ac2c2269d573477e23908462fccbf945c3303a9fb1f'
- '4408c8d4cb6d072929ba6e7f3edac170bfea8f54eb009ee7ceaa131a0c1fa92e'
+sha256sums=('dd6579c170eecd8d1f366461575e9754e44200e0b9fefde20941e15cb6729711'
+ '4c2adc718e53f36e38202aabf6518ceaa0244e281567433489b0a4e6dab1dc2f'
+ '13cf0e23176787fcaa039c0bd230745e5cf5699877a51e77694c97392dc0973d'
+ '3a087d34cf2890d85d1e2fad0d63e9db82d47c400994dfe6f0e2ee8bcedb4195'
+ '581fb67410dad60fbe484294e4da2fed0de2487caabe33d595fa7abdf72e0f59'
'09bfac44104f4ccda4c228053f689c947b3e97da9a4ab6fa34ce061ee83d0322'
'478340d5760a9bd6c549e19b1b5d1c5b4933ebf5f8cfb2b3e2d70d07443fe232'
- 'a1145e83d775101b28dcdceb3ca076fc7e9a4b9f69a1a2236d0c97ad39afb3d3'
+ 'b1ca3f17959be4fb6c031563b1ee587b7e990166c41b9d5b9dce2f91bf01fe1c'
+ '14d86770eaaead42e244007ebe5a94d188f8668c2598fa6042ada87a90cae671'
'4999fded897af692f4974f0a3e3bbb215193519918a1fa9b31ed51e74a2dccb9')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@@ -58,7 +60,9 @@ _google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
prepare() {
cd "$srcdir/$pkgname-$pkgver"
- patch -Np0 -i "$srcdir/chromium-gn-r0.patch"
+ # Build fixes (patches from Gentoo)
+ patch -Np0 -i "$srcdir/chromium-gn-r1.patch"
+ patch -Np0 -i "$srcdir/chromium-depot-tools-r0.patch"
# Use Python 2
find . -type f -exec sed -i -r \
@@ -114,7 +118,6 @@ build() {
-Duse_system_flac=1
-Duse_system_ffmpeg=0
-Duse_system_harfbuzz=1
- -Duse_system_icu=1
-Duse_system_libevent=1
-Duse_system_libjpeg=1
-Duse_system_libpng=1
@@ -132,7 +135,7 @@ build() {
build/linux/unbundle/replace_gyp_files.py "${_chromium_conf[@]}"
build/gyp_chromium -f make --depth=. "${_chromium_conf[@]}"
- make chrome chrome_sandbox BUILDTYPE=Release
+ make BUILDTYPE=Release chrome chrome_sandbox chromedriver
}
package() {
@@ -143,12 +146,15 @@ package() {
install -Dm4755 -o root -g root out/Release/chrome_sandbox \
"$pkgdir/usr/lib/chromium/chrome-sandbox"
+ install -D out/Release/chromedriver "$pkgdir/usr/lib/chromium/chromedriver"
+
cp out/Release/{*.pak,libffmpegsumo.so,nacl_helper{,_bootstrap}} \
out/Release/{libppGoogleNaClPluginChrome.so,nacl_irt_*.nexe} \
"$pkgdir/usr/lib/chromium/"
# Manually strip binaries so that 'nacl_irt_*.nexe' is left intact
strip $STRIP_BINARIES "$pkgdir/usr/lib/chromium/"{chromium,chrome-sandbox} \
+ "$pkgdir/usr/lib/chromium/chromedriver" \
"$pkgdir/usr/lib/chromium/"nacl_helper{,_bootstrap}
strip $STRIP_SHARED "$pkgdir/usr/lib/chromium/libffmpegsumo.so" \
"$pkgdir/usr/lib/chromium/libppGoogleNaClPluginChrome.so"
@@ -156,7 +162,7 @@ package() {
# Allow users to override command-line options
install -Dm644 "$srcdir/chromium.default" "$pkgdir/etc/chromium/default"
- cp -a out/Release/locales "$pkgdir/usr/lib/chromium/"
+ cp -a out/Release/locales out/Release/icudtl.dat "$pkgdir/usr/lib/chromium/"
install -Dm644 out/Release/chrome.1 "$pkgdir/usr/share/man/man1/chromium.1"
@@ -174,6 +180,7 @@ package() {
done
install -D "$srcdir/chromium.sh" "$pkgdir/usr/bin/chromium"
+ ln -s /usr/lib/chromium/chromedriver "$pkgdir/usr/bin/chromedriver"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/chromium/LICENSE"
}
diff --git a/chromium-depot-tools-r0.patch b/chromium-depot-tools-r0.patch
new file mode 100644
index 000000000000..19b92ce40d07
--- /dev/null
+++ b/chromium-depot-tools-r0.patch
@@ -0,0 +1,11 @@
+--- build/gyp_chromium.orig 2014-01-29 01:22:52.527247671 +0000
++++ build/gyp_chromium 2014-01-29 01:23:49.857623290 +0000
+@@ -38,8 +38,6 @@
+ sys.path.insert(1, os.path.join(chrome_src, 'third_party', 'WebKit',
+ 'Source', 'build', 'scripts'))
+
+-import find_depot_tools
+-
+ # On Windows, Psyco shortens warm runs of build/gyp_chromium by about
+ # 20 seconds on a z600 machine with 12 GB of RAM, from 90 down to 70
+ # seconds. Conversely, memory usage of build/gyp_chromium with Psyco
diff --git a/chromium-gn-r0.patch b/chromium-gn-r1.patch
index 5cb8c0ebc82a..9d3071de56d2 100644
--- a/chromium-gn-r0.patch
+++ b/chromium-gn-r1.patch
@@ -1,12 +1,11 @@
---- build/gyp_chromium.orig 2013-12-11 03:07:03.941915587 +0000
-+++ build/gyp_chromium 2013-12-11 03:07:29.812073301 +0000
-@@ -221,9 +221,6 @@
+--- build/gyp_chromium.orig 2014-01-16 22:55:50.292718339 +0000
++++ build/gyp_chromium 2014-01-16 23:15:17.890248708 +0000
+@@ -370,8 +370,6 @@
+ args.append('--check')
supplemental_includes = GetSupplementalFiles()
-
- if not RunGN(supplemental_includes):
- sys.exit(1)
--
args.extend(
['-I' + i for i in additional_include_files(supplemental_includes, args)])