summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvangelos Foutras2022-12-14 08:51:28 +0000
committerEvangelos Foutras2022-12-14 08:51:28 +0000
commit8110279011b757c42c655438b7dbfa5d8df436c7 (patch)
tree70f347d31c196c26d1f3883d76518b1ea5835cf5
parenta90c5ad1c9c0b947d86223d6f9fb30f6cf897c19 (diff)
downloadaur-8110279011b757c42c655438b7dbfa5d8df436c7.tar.gz
build with Qt5 support (FS#76769)
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e06338beb18..9b73733625f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=chromium
-pkgver=108.0.5359.98
-pkgrel=2
+pkgver=108.0.5359.124
+pkgrel=1
_launcher_ver=8
_gcc_patchset=2
pkgdesc="A web browser built for speed, simplicity, and security"
@@ -16,9 +16,10 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'libva'
'wayland' 'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'gn' 'ninja' 'clang' 'lld' 'gperf' 'nodejs' 'pipewire'
- 'java-runtime-headless' 'git')
+ 'qt5-base' 'java-runtime-headless' 'git')
optdepends=('pipewire: WebRTC desktop sharing under Wayland'
'kdialog: support for native dialogs in Plasma'
+ 'qt5-base: enable Qt5 with --enable-features=AllowQt'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
'kwallet: support for storing passwords in KWallet on Plasma')
options=('debug' '!lto') # Chromium adds its own flags for ThinLTO
@@ -33,7 +34,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
disable-GlobalMediaControlsCastStartStop.patch
angle-wayland-include-protocol.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('60b6137971e3cb2947477f654491ed4f517ab88ea2807fa3b89fcce34b83561e'
+sha256sums=('d48dfac2a61b14a5d7d2f460b09b70ef3ab88e27b82e3173938cb54eaa612a75'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'40ef8af65e78901bb8554eddbbb5ebc55c0b8e7927f6ca51b2a353d1c7c50652'
'9015b9d6d5b4c1e7248d6477a4b4b6bd6a3ebdc57225d2d8efcd79fc61790716'
@@ -174,7 +175,6 @@ build() {
'link_pulseaudio=true'
'use_custom_libcxx=false'
'use_gnome_keyring=false'
- 'use_qt=false' # look into enabling this
'use_sysroot=false'
'use_system_libwayland=true'
'use_system_wayland_scanner=true'
@@ -255,6 +255,7 @@ package() {
chrome_100_percent.pak
chrome_200_percent.pak
chrome_crashpad_handler
+ libqt5_shim.so
resources.pak
v8_context_snapshot.bin