summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvangelos Foutras2018-02-03 17:09:20 +0000
committerEvangelos Foutras2018-02-03 17:09:20 +0000
commita3ad5ec52afe3449e053bc00657aacbabccf99a4 (patch)
tree8a8f0d0db1f2353c3c2902de09c710a6e01c9297
parenta09bd1727cae38b6cf61a25cf1a0e99d3431eafa (diff)
downloadaur-a3ad5ec52afe3449e053bc00657aacbabccf99a4.tar.gz
Switch to system libvpx now that it's recent enough.
- Disable generation of unwind tables using cflags instead of the exclude_unwind_tables=true GN flag; the latter stopped being configurable in M63. - Omit use_gtk3=true; it was made the default a few releases back.
-rw-r--r--PKGBUILD16
-rw-r--r--chromium-exclude_unwind_tables.patch33
2 files changed, 7 insertions, 42 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f7e0e27dfc8..19efc5619a30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=chromium
pkgver=64.0.3282.140
-pkgrel=1
+pkgrel=2
_launcher_ver=5
pkgdesc="A web browser built for speed, simplicity, and security"
arch=('x86_64')
@@ -28,7 +28,6 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
chromium-skia-harmony.patch
chromium-memcpy-r0.patch
chromium-clang-r2.patch
- chromium-exclude_unwind_tables.patch
chromium-widevine.patch)
sha256sums=('146afbab37982c52251e5c71b6e19e6e7053b527217fe1da9966c794478c29ce'
'4dc3428f2c927955d9ae117f2fb24d098cc6dd67adb760ac9c82b522ec8b0587'
@@ -38,7 +37,6 @@ sha256sums=('146afbab37982c52251e5c71b6e19e6e7053b527217fe1da9966c794478c29ce'
'feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3'
'455f0029987d9f0532bd9a5250669af5146a9c2b65b776d4a6e2499e8aca7bb4'
'4495e8b29dae242c79ffe4beefc5171eb3c7aacb7e9aebfd2d4d69b9d8c958d3'
- '9478f1ec1a3c53425306cf41c2d0555c215a4f106955d9d6adfff38044530ce8'
'd6fdcb922e5a7fbe15759d39ccc8ea4225821c44d98054ce0f23f9d1f00c9808')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
@@ -53,7 +51,7 @@ readonly -A _system_libs=(
[libdrm]=
[libjpeg]=libjpeg
#[libpng]=libpng # https://crbug.com/752403#c10
- #[libvpx]=libvpx # https://bugs.gentoo.org/611394
+ [libvpx]=libvpx
[libwebp]=libwebp
#[libxml]=libxml2 # https://crbug.com/736026
[libxslt]=libxslt
@@ -96,9 +94,6 @@ prepare() {
sed "s/@WIDEVINE_VERSION@/Pinkie Pie/" ../chromium-widevine.patch |
patch -Np1
- # https://chromium-review.googlesource.com/c/chromium/src/+/712575
- patch -Np1 -i ../chromium-exclude_unwind_tables.patch
-
# https://crbug.com/772655
patch -Np1 -i ../chromium-use-fromUTF8-for-UnicodeString-construction.patch
@@ -183,7 +178,6 @@ build() {
'link_pulseaudio=true'
'use_system_freetype=true'
'use_system_harfbuzz=true'
- 'use_gtk3=true'
'use_gconf=false'
'use_gnome_keyring=false'
'use_gold=false'
@@ -201,7 +195,11 @@ build() {
)
if check_option strip y; then
- _flags+=('exclude_unwind_tables=true')
+ # https://chromium-review.googlesource.com/c/chromium/src/+/712575
+ # _flags+=('exclude_unwind_tables=true')
+ CFLAGS+=' -fno-unwind-tables -fno-asynchronous-unwind-tables'
+ CXXFLAGS+=' -fno-unwind-tables -fno-asynchronous-unwind-tables'
+ CPPFLAGS+=' -DNO_UNWIND_TABLES'
fi
python2 tools/gn/bootstrap/bootstrap.py --gn-gen-args "${_flags[*]}"
diff --git a/chromium-exclude_unwind_tables.patch b/chromium-exclude_unwind_tables.patch
deleted file mode 100644
index 1961f15e412d..000000000000
--- a/chromium-exclude_unwind_tables.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/build/config/compiler/compiler.gni b/build/config/compiler/compiler.gni
-index ad40fd9..50e19a4 100644
---- a/build/config/compiler/compiler.gni
-+++ b/build/config/compiler/compiler.gni
-@@ -68,19 +68,19 @@
-
- # Whether or not we should use position independent code.
- use_pic = true
-+
-+ # Exclude unwind tables for official builds as unwinding can be done from
-+ # stack dumps produced by Crashpad at a later time "offline" in the crash
-+ # server. For unofficial (e.g. development) builds and non-Chrome branded
-+ # (e.g. Cronet which doesn't use Crashpad, crbug.com/479283) builds it's
-+ # useful to be able to unwind at runtime.
-+ exclude_unwind_tables =
-+ (is_chrome_branded && is_official_build) ||
-+ (is_chromecast && !is_cast_desktop_build && !is_debug && !is_fuchsia)
- }
-
- assert(!is_cfi || use_thin_lto, "CFI requires ThinLTO")
-
--# Exclude unwind tables for official builds as unwinding can be done from stack
--# dumps produced by Crashpad at a later time "offline" in the crash server.
--# For unofficial (e.g. development) builds and non-Chrome branded (e.g. Cronet
--# which doesn't use Crashpad, crbug.com/479283) builds it's useful to be able
--# to unwind at runtime.
--exclude_unwind_tables =
-- (is_chrome_branded && is_official_build) ||
-- (is_chromecast && !is_cast_desktop_build && !is_debug && !is_fuchsia)
--
- # If true, optimize for size. Does not affect windows builds.
- # Linux & Mac favor speed over size.
- # TODO(brettw) it's weird that Mac and desktop Linux are different. We should