summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2022-03-28 21:54:49 +0200
committerNicolas Iooss2022-03-28 21:54:49 +0200
commita2ef8b3f14aeaa123459b2fa92db647204df59a9 (patch)
tree0fff4826f8d4e112909393597a21c696f19bc4a2
parent0d221f0063f206a8aa68a16439e568ebabf6889e (diff)
downloadaur-a2ef8b3f14aeaa123459b2fa92db647204df59a9.tar.gz
cronie-selinux 1.6.0-2 update
-rw-r--r--.SRCINFO14
-rw-r--r--0001-crontab-use-bold-colors.patch26
-rw-r--r--0001-fix-range-entries.patch21
-rw-r--r--PKGBUILD16
4 files changed, 38 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44820efae58f..671fa119c565 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cronie-selinux
pkgdesc = Daemon that runs specified programs at scheduled times and related tools with SELinux support
- pkgver = 1.5.7
+ pkgver = 1.6.0
pkgrel = 2
url = https://github.com/cronie-crond/cronie/
arch = i686
@@ -15,8 +15,8 @@ pkgbase = cronie-selinux
optdepends = smtp-server: send job output via email
optdepends = smtp-forwarder: forward job output to email server
provides = cron
- provides = cronie=1.5.7-2
- provides = selinux-cronie=1.5.7-2
+ provides = cronie=1.6.0-2
+ provides = selinux-cronie=1.6.0-2
conflicts = cron
conflicts = cronie
conflicts = selinux-cronie
@@ -24,14 +24,14 @@ pkgbase = cronie-selinux
backup = etc/pam.d/crond
backup = etc/cron.d/0hourly
backup = etc/anacrontab
- source = https://github.com/cronie-crond/cronie/releases/download/cronie-1.5.7/cronie-1.5.7.tar.gz
- source = 0001-crontab-use-bold-colors.patch
+ source = https://github.com/cronie-crond/cronie/releases/download/cronie-1.6.0/cronie-1.6.0.tar.gz
+ source = 0001-fix-range-entries.patch
source = 80-cronie.hook
source = service
source = pam.d
source = deny
- sha256sums = 538bcfaf2e986e5ae1edf6d1472a77ea8271d6a9005aee2497a9ed6e13320eb3
- sha256sums = 2c9a2f386f23779907c468023538b195cd3e3c61fa16e19f036ee13a031f1c3a
+ sha256sums = 3f7cc263d21838b53a9943eb2a26b862059e2ae36c3f11789ac33cd6818e3628
+ sha256sums = 29830d76a12992e1c74249d2aa577b8f6c52fc041beef5b4a066bed1004ddf84
sha256sums = f85e9a68bf3bf446f8a6167f068371c06afffe11ca71935d8ee5487b38b2c9db
sha256sums = ac3ff3c8a5ce1b6367b06877b4b12ff74e7f18a3c510fb9f80d6ea6b6321e3b1
sha256sums = 00864268b491bab8c66400a4a4b4bf85f168a6e44e85676105e084940924090c
diff --git a/0001-crontab-use-bold-colors.patch b/0001-crontab-use-bold-colors.patch
deleted file mode 100644
index 5afb46c0558e..000000000000
--- a/0001-crontab-use-bold-colors.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 116ab7eeb7dff736c83389746f22700d9f6a7dd8 Mon Sep 17 00:00:00 2001
-From: Christian Hesse <mail@eworm.de>
-Date: Mon, 29 Mar 2021 15:34:46 +0200
-Subject: [PATCH 1/1] crontab: use bold colors
-
-Dark colors (especially blue) on dark background are hard to read.
-Let's make these bold.
----
- src/crontab.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/crontab.c b/src/crontab.c
-index af3db23..240c112 100644
---- a/src/crontab.c
-+++ b/src/crontab.c
-@@ -66,8 +66,8 @@
-
- #define NHEADER_LINES 0
-
--#define COMMENT_COLOR "\x1B[34m"
--#define ERROR_COLOR "\x1B[31m"
-+#define COMMENT_COLOR "\x1B[34;1m"
-+#define ERROR_COLOR "\x1B[31;1m"
- #define RESET_COLOR "\x1B[0m"
-
- enum opt_t {
diff --git a/0001-fix-range-entries.patch b/0001-fix-range-entries.patch
new file mode 100644
index 000000000000..cd5cbe75d594
--- /dev/null
+++ b/0001-fix-range-entries.patch
@@ -0,0 +1,21 @@
+From 62e53f1cdb9c1e12a01ee7814c92cd937d50328d Mon Sep 17 00:00:00 2001
+From: w30023233 <wangyuhang27@huawei.com>
+Date: Wed, 23 Mar 2022 15:40:01 +0800
+Subject: Fix regression in handling 1-5 crontab entries
+
+---
+ src/entry.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/entry.c b/src/entry.c
+index e9e258b..bb7cb62 100644
+--- a/src/entry.c
++++ b/src/entry.c
+@@ -595,6 +595,7 @@ get_range(bitstr_t * bits, int low, int high, const char *names[],
+ return (EOF);
+
+ case R_RANGE:
++ unget_char(ch, file);
+ if (get_number(&num2, low, names, file) != EOF) {
+ state = R_RANGE_NUM2;
+ break;
diff --git a/PKGBUILD b/PKGBUILD
index 45f50904737a..e1104f3ac257 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname='cronie-selinux'
-pkgver=1.5.7
+pkgver=1.6.0
pkgrel=2
pkgdesc='Daemon that runs specified programs at scheduled times and related tools with SELinux support'
url='https://github.com/cronie-crond/cronie/'
@@ -22,13 +22,13 @@ provides=('cron' "${pkgname/-selinux}=${pkgver}-${pkgrel}"
"selinux-${pkgname/-selinux}=${pkgver}-${pkgrel}")
groups=('selinux')
source=("https://github.com/cronie-crond/cronie/releases/download/${pkgname/-selinux}-${pkgver}/${pkgname/-selinux}-${pkgver}.tar.gz"
- '0001-crontab-use-bold-colors.patch'
+ '0001-fix-range-entries.patch'
'80-cronie.hook'
'service'
'pam.d'
'deny')
-sha256sums=('538bcfaf2e986e5ae1edf6d1472a77ea8271d6a9005aee2497a9ed6e13320eb3'
- '2c9a2f386f23779907c468023538b195cd3e3c61fa16e19f036ee13a031f1c3a'
+sha256sums=('3f7cc263d21838b53a9943eb2a26b862059e2ae36c3f11789ac33cd6818e3628'
+ '29830d76a12992e1c74249d2aa577b8f6c52fc041beef5b4a066bed1004ddf84'
'f85e9a68bf3bf446f8a6167f068371c06afffe11ca71935d8ee5487b38b2c9db'
'ac3ff3c8a5ce1b6367b06877b4b12ff74e7f18a3c510fb9f80d6ea6b6321e3b1'
'00864268b491bab8c66400a4a4b4bf85f168a6e44e85676105e084940924090c'
@@ -38,10 +38,14 @@ backup=('etc/cron.deny'
'etc/cron.d/0hourly'
'etc/anacrontab')
-build() {
+prepare() {
cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
- patch -Np1 < ../0001-crontab-use-bold-colors.patch
+ patch -Np1 < ../0001-fix-range-entries.patch
+}
+
+build() {
+ cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
./configure \
--prefix=/usr \