summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2019-09-20 18:37:31 +0200
committerNicolas Iooss2019-09-20 18:37:31 +0200
commite2a09b3cb8379c005f6515fe0ebed5a095ba91bb (patch)
treeb15303ae2b888e5662882f4efea3656af6ab2435
parentb9e4a61aed11a8ba84537b179ce2ad1c7231705e (diff)
downloadaur-e2a09b3cb8379c005f6515fe0ebed5a095ba91bb.tar.gz
cronie-selinux 1.5.4-2 update
-rw-r--r--.SRCINFO8
-rw-r--r--0001-do-not-log-carriage-return.patch35
-rw-r--r--PKGBUILD9
3 files changed, 48 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22d49be1e53a..c47c5c464aa4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cronie-selinux
pkgdesc = Daemon that runs specified programs at scheduled times and related tools with SELinux support
pkgver = 1.5.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cronie-crond/cronie/
arch = i686
arch = x86_64
@@ -14,8 +14,8 @@ pkgbase = cronie-selinux
optdepends = smtp-server: send job output via email
optdepends = smtp-forwarder: forward job output to email server
provides = cron
- provides = cronie=1.5.4-1
- provides = selinux-cronie=1.5.4-1
+ provides = cronie=1.5.4-2
+ provides = selinux-cronie=1.5.4-2
conflicts = cron
conflicts = cronie
conflicts = selinux-cronie
@@ -24,10 +24,12 @@ pkgbase = cronie-selinux
backup = etc/cron.d/0hourly
backup = etc/anacrontab
source = https://github.com/cronie-crond/cronie/releases/download/cronie-1.5.4-final/cronie-1.5.4.tar.gz
+ source = 0001-do-not-log-carriage-return.patch
source = service
source = pam.d
source = deny
sha256sums = af8970559cad4262f8ffd7ec72abf682d2dcce04fdfb8f206a71d96566aba882
+ sha256sums = 595e96997afe506ad93a98896830f3651667f56406a5ae67f4bcf513cfcb45ad
sha256sums = ac3ff3c8a5ce1b6367b06877b4b12ff74e7f18a3c510fb9f80d6ea6b6321e3b1
sha256sums = 00864268b491bab8c66400a4a4b4bf85f168a6e44e85676105e084940924090c
sha256sums = ae6e533ecdfc1bd2dd80a9e25acb0260cbe9f00c4e4abee93d552b3660f263fc
diff --git a/0001-do-not-log-carriage-return.patch b/0001-do-not-log-carriage-return.patch
new file mode 100644
index 000000000000..d8e450a284f7
--- /dev/null
+++ b/0001-do-not-log-carriage-return.patch
@@ -0,0 +1,35 @@
+From cdc44c2b78ae88bf62bb870969ba814d3a79e71c Mon Sep 17 00:00:00 2001
+From: Christian Hesse <mail@eworm.de>
+Date: Mon, 9 Sep 2019 10:17:32 +0200
+Subject: [PATCH 1/1] do not log carriage return
+
+Some commands (like ssh) end their output with carriage return (\r) and
+new line (\n). Just cutting the new line before sending to syslog may
+have undesired effects of unprintable characters. Reading cronie logs
+with journalctl I can see:
+
+Sep 06 16:50:01 linux CROND[152575]: [96B blob data]
+
+Adding switch --all for unprintable characters it shows:
+
+Sep 06 16:50:01 linux CROND[152575]: (root) CMDOUT (Warning: Permanently
+added '10.52.33.217' (ED25519) to the list of known hosts.^M)
+
+Just skip carriage return for syslog to prevent this.
+---
+ src/do_command.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/do_command.c b/src/do_command.c
+index 45c49f7..ed56775 100644
+--- a/src/do_command.c
++++ b/src/do_command.c
+@@ -506,6 +506,8 @@ static int child_process(entry * e, char **jobenv) {
+ */
+
+ while (EOF != (ch = getc(in))) {
++ if (ch == '\r')
++ continue;
+ bytes++;
+ if (mail)
+ putc(ch, mail);
diff --git a/PKGBUILD b/PKGBUILD
index 5f4261570e89..9685c97c71bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname='cronie-selinux'
pkgver=1.5.4
-pkgrel=1
+pkgrel=2
pkgdesc='Daemon that runs specified programs at scheduled times and related tools with SELinux support'
url='https://github.com/cronie-crond/cronie/'
license=('custom:BSD')
@@ -18,10 +18,12 @@ depends=('pam-selinux' 'bash' 'run-parts' 'libselinux')
optdepends=('smtp-server: send job output via email'
'smtp-forwarder: forward job output to email server')
source=("https://github.com/cronie-crond/cronie/releases/download/${pkgname/-selinux}-${pkgver}-final/${pkgname/-selinux}-${pkgver}.tar.gz"
+ '0001-do-not-log-carriage-return.patch'
'service'
'pam.d'
'deny')
sha256sums=('af8970559cad4262f8ffd7ec72abf682d2dcce04fdfb8f206a71d96566aba882'
+ '595e96997afe506ad93a98896830f3651667f56406a5ae67f4bcf513cfcb45ad'
'ac3ff3c8a5ce1b6367b06877b4b12ff74e7f18a3c510fb9f80d6ea6b6321e3b1'
'00864268b491bab8c66400a4a4b4bf85f168a6e44e85676105e084940924090c'
'ae6e533ecdfc1bd2dd80a9e25acb0260cbe9f00c4e4abee93d552b3660f263fc')
@@ -36,6 +38,11 @@ provides=('cron' "${pkgname/-selinux}=${pkgver}-${pkgrel}"
"selinux-${pkgname/-selinux}=${pkgver}-${pkgrel}")
groups=('selinux')
+prepare() {
+ cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
+ patch -Np1 < ../0001-do-not-log-carriage-return.patch
+}
+
build() {
cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
./configure \