summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdriĆ  Arrufat2015-07-15 19:44:26 +0200
committerAdriĆ  Arrufat2015-07-15 19:44:26 +0200
commitb1661f3c0cb44a2e8190ec5f02980c34ca170789 (patch)
tree6385516f8d8049986e7a002fe89677f57e8b317f
downloadaur-b1661f3c0cb44a2e8190ec5f02980c34ca170789.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
-rw-r--r--cronopete.install12
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4770427dc6cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cronopete
+ pkgdesc = An Apple's Time Machine clone
+ pkgver = 3.16.0
+ pkgrel = 1
+ url = http://www.rastersoft.com/programas/cronopete.html
+ install = cronopete.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = gtk3
+ depends = vala
+ depends = gsl
+ depends = libgee
+ source = https://github.com/rastersoft/cronopete/archive/v3.16.0.tar.gz
+ md5sums = 1f8200dcf187606554e637bf213c2f80
+
+pkgname = cronopete
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58d855d709b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Adria Arrufat <swiftscythe at gmail _dot_com>
+
+pkgname=cronopete
+pkgver=3.16.0
+pkgrel=1
+pkgdesc="An Apple's Time Machine clone"
+arch=('i686' 'x86_64')
+url="http://www.rastersoft.com/programas/cronopete.html"
+license=('GPL2')
+depends=('gtk3' 'vala' 'gsl' 'libgee')
+source=(https://github.com/rastersoft/cronopete/archive/v${pkgver}.tar.gz)
+md5sums=('1f8200dcf187606554e637bf213c2f80')
+install=${pkgname}.install
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DNO_APPINDICATOR=on ..
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}/build
+ make DESTDIR=${pkgdir} install
+}
diff --git a/cronopete.install b/cronopete.install
new file mode 100644
index 000000000000..f6fa9b3d4be8
--- /dev/null
+++ b/cronopete.install
@@ -0,0 +1,12 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -f -q -t /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}