summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-04 22:12:45 +0300
committerDimitris Kiziridis2020-04-04 22:12:45 +0300
commit5eb371b091a07bf2058adb1b4cf6b20f7723bfed (patch)
tree8cfe457e4c1b0cc4d6483c2a94dd1bc96243539f
parent997cd5f249df252d1c45623bc4f1a10216ad41ae (diff)
downloadaur-5eb371b091a07bf2058adb1b4cf6b20f7723bfed.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5398309e5f0f..fd5105e94034 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = cronsun-bin
pkgdesc = A Distributed, Fault-Tolerant Cron-Style Job System
pkgver = 0.3.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/shunfei/cronsun
arch = x86_64
- license = Apache2
+ license = Apache-2.0
depends = mongodb
depends = etcd
provides = cronsun
diff --git a/PKGBUILD b/PKGBUILD
index 15ee69e26ad0..d28938f50a91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,18 @@
pkgname=cronsun-bin
pkgver=0.3.5
-pkgrel=1
+pkgrel=2
pkgdesc='A Distributed, Fault-Tolerant Cron-Style Job System'
arch=('x86_64')
url="https://github.com/shunfei/cronsun"
-license=('Apache2')
+license=('Apache-2.0')
provides=('cronsun')
depends=('mongodb' 'etcd')
source=("${url}/releases/download/v0.3.5/cronsun-v${pkgver}-linux-amd64.zip")
md5sums=('2759e389ae41da8ddbd4011d7fef0a99')
package() {
- cd "${srcdir}/cronsun-v${pkgver}"
- install -Dm755 {cronnode,cronweb,csctl} -t "${pkgdir}/usr/bin"
- install -Dm644 conf/* -t "${pkgdir}/etc/conf.d/cronsun"
+ install -Dm755 "${srcdir}/cronsun-v${pkgver}"/{cronnode,cronweb,csctl} -t "${pkgdir}/usr/bin"
+ install -Dm644 "${srcdir}/cronsun-v${pkgver}"/conf/* -t "${pkgdir}/etc/conf.d/cronsun"
}
# vim:set ts=2 sw=2 et: \ No newline at end of file