summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2020-05-19 23:04:32 +0200
committerJose Riha2020-05-19 23:04:32 +0200
commita7398a6acc50cbdf5ee984d58a1e4ff0a7a0a4a5 (patch)
tree5922ce464e61b583d563fd0013e97fca60938e7c
parentbc4c50ce6f0848bc6fab8f06b8b4140bd1958d48 (diff)
downloadaur-a7398a6acc50cbdf5ee984d58a1e4ff0a7a0a4a5.tar.gz
Update
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
-rw-r--r--python3_fix.patch19
3 files changed, 8 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d4c95cc1058..dbc491fa9b6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cropgui
pkgdesc = a simple tool for lossless jpeg cropping
- pkgver = 0.4
- pkgrel = 2
+ pkgver = 0.5
+ pkgrel = 1
url = https://github.com/jepler/cropgui
arch = any
license = GPL
@@ -10,9 +10,8 @@ pkgbase = cropgui
depends = imagemagick
depends = pygtk
depends = perl-image-exiftool
- source = https://github.com/jepler/cropgui/archive/v0.4.tar.gz
- source = python3_fix.patch
- md5sums = a761991bf98793da29390f960dffe9a2
+ source = https://github.com/jepler/cropgui/archive/v0.5.tar.gz
+ md5sums = 989b837c59ac1fe5b3fa99af341f8ca8
md5sums = 648252816c414e010193e21069cc163a
pkgname = cropgui
diff --git a/PKGBUILD b/PKGBUILD
index 66eb4273fd34..8ca0dedf573e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,16 @@
pkgname=cropgui
arch=('any')
-pkgver=0.4
-pkgrel=2
+pkgver=0.5
+pkgrel=1
pkgdesc="a simple tool for lossless jpeg cropping"
license=('GPL')
url="https://github.com/jepler/cropgui"
depends=('libjpeg' 'python-pillow' 'imagemagick' 'pygtk' 'perl-image-exiftool')
-source=("https://github.com/jepler/cropgui/archive/v${pkgver}.tar.gz" "python3_fix.patch")
-md5sums=('a761991bf98793da29390f960dffe9a2'
+source=("https://github.com/jepler/cropgui/archive/v${pkgver}.tar.gz")
+md5sums=('989b837c59ac1fe5b3fa99af341f8ca8'
'648252816c414e010193e21069cc163a')
-prepare() {
- patch -p1 -i "${srcdir}/python3_fix.patch"
-}
-
package() {
cd $srcdir/$pkgname-$pkgver
./install.sh -f gtk -t $pkgdir -p /usr -P /usr/bin/python
diff --git a/python3_fix.patch b/python3_fix.patch
deleted file mode 100644
index 0b86d6ff9e16..000000000000
--- a/python3_fix.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -aur src.orig/cropgui-0.4/install.sh src/cropgui-0.4/install.sh
---- src.orig/cropgui-0.4/install.sh 2020-04-08 09:49:34.394817453 +0200
-+++ src/cropgui-0.4/install.sh 2020-04-08 09:49:52.994691249 +0200
-@@ -1,5 +1,5 @@
- #!/bin/sh
--PYTHON=python2
-+PYTHON=python3
- BINDIR=$HOME/bin; LIBDIR=$HOME/lib/python SHAREDIR=$HOME/share
-
- default_flavor () {
-@@ -12,7 +12,7 @@
- }
-
- site_packages () {
-- $PYTHON -c 'import distutils.sysconfig; print distutils.sysconfig.get_python_lib()'
-+ $PYTHON -c 'import distutils.sysconfig; print(distutils.sysconfig.get_python_lib())'
- }
-
- usage () {