summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2017-03-02 11:02:35 +1100
committerRhinoceros2017-03-02 11:02:35 +1100
commit23fac6f79247cae66dd4cb7a9f6d6536ef0a6494 (patch)
tree9d073b9877891e95b44fc94a45f415a863fd7405
parent3c2469711fb37d2b546151552cd210dc31648254 (diff)
downloadaur-23fac6f79247cae66dd4cb7a9f6d6536ef0a6494.tar.gz
Update to 1:0.2.r60.g541e812-1
* Add depends as per upstream readme. It's likely still missing others. * Use correct pkgver() * Don't cd $srcdir * Minor style changes
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a409891ef917..61a047b0798d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Mar 2 00:02:32 UTC 2017
pkgbase = cropgui-git
pkgdesc = A GTK GUI for lossless JPEG cropping (and rotating)
- pkgver = b3a00e
+ pkgver = 0.2.r60.g541e812
pkgrel = 1
+ epoch = 1
url = https://emergent.unpythonic.net/01248401946
arch = any
license = GPL
makedepends = git
depends = python
depends = python2-pillow
+ depends = libjpeg-turbo
+ depends = imagemagick
provides = cropgui
conflicts = cropgui
source = cropgui-git::git+https://github.com/jepler/cropgui
diff --git a/PKGBUILD b/PKGBUILD
index be1e2b0c9d23..dd5741fa0efc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
-# Maintainer: rafaqzsu <rafaqzsu [at] gmail (dot) com>
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Contributor: rafaqzsu <rafaqzsu [at] gmail (dot) com>
+
pkgname=cropgui-git
-pkgver=349125
+pkgver=0.2.r60.g541e812
pkgrel=1
epoch=1
-pkgdesc="A GTK GUI for lossless JPEG cropping (and rotating)"
+pkgdesc='A GTK GUI for lossless JPEG cropping (and rotating)'
arch=('any')
url="https://emergent.unpythonic.net/01248401946"
license=('GPL')
-depends=('python'
- 'python2-pillow')
+depends=('python' 'python2-pillow' 'libjpeg-turbo' 'imagemagick')
makedepends=('git')
provides=('cropgui')
conflicts=('cropgui')
@@ -16,11 +17,11 @@ source=("$pkgname::git+https://github.com/jepler/cropgui")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$pkgname"
./install.sh -f gtk -t $pkgdir -p /usr -P python2
}