summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Schouten2015-12-01 00:19:31 +1100
committerRafael Schouten2015-12-01 00:19:31 +1100
commitc349125db122589304eccd223b2f4fe024aa523b (patch)
tree4a22605186d30a7839b5ecb48aea5908b2429a5e
parent5f1438d5eaccec3a1b2bf764dc37b8c0bfb0e196 (diff)
downloadaur-c349125db122589304eccd223b2f4fe024aa523b.tar.gz
remove patch and update
-rw-r--r--PKGBUILD7
-rw-r--r--python2.patch54
2 files changed, 1 insertions, 60 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d9382b9c1cba..fa9e3ee5c9ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: rafaqzsu <rafaqzsu [at] gmail (dot) com>
pkgname=cropgui-git
-pkgver=b3a00e
+pkgver=db8091
pkgrel=1
pkgdesc="A GTK GUI for lossless JPEG cropping (and rotating)"
arch=('any')
@@ -18,11 +18,6 @@ pkgver() {
git describe --always | sed -e 's|-|.|g' -e '1s|^.||'
}
-prepare() {
- cd "${srcdir}"/$pkgname
- git apply ../../python2.patch
-}
-
package() {
cd "$srcdir/$pkgname"
./install.sh -f gtk -t $pkgdir -p /usr -P python2
diff --git a/python2.patch b/python2.patch
deleted file mode 100644
index 65e9c4f26227..000000000000
--- a/python2.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From d6b852cfb792f075831bcdd64aa51583e097a632 Mon Sep 17 00:00:00 2001
-From: rafaqzsu <rafaqzsu@gmail.com>
-Date: Thu, 26 Nov 2015 17:49:47 +1100
-Subject: [PATCH] use python2 binary
-
----
- cropgtk.py | 2 +-
- cropgui.py | 2 +-
- install.sh | 4 ++--
- 3 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/cropgtk.py b/cropgtk.py
-index 135b6a8..b796d1f 100755
---- a/cropgtk.py
-+++ b/cropgtk.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
- # cropgui, a graphical front-end for lossless jpeg cropping
- # Copyright (C) 2009 Jeff Epler <jepler@unpythonic.net>
- # This program is free software; you can redistribute it and/or modify
-diff --git a/cropgui.py b/cropgui.py
-index 121d016..9299fde 100755
---- a/cropgui.py
-+++ b/cropgui.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
- # cropgui, a graphical front-end for lossless jpeg cropping
- # Copyright (C) 2009 Jeff Epler <jepler@unpythonic.net>
- # This program is free software; you can redistribute it and/or modify
-diff --git a/install.sh b/install.sh
-index f2421cf..05a916f 100755
---- a/install.sh
-+++ b/install.sh
-@@ -1,5 +1,5 @@
- #!/bin/sh
--PYTHON=python
-+PYTHON=python2
- BINDIR=$HOME/bin; LIBDIR=$HOME/lib/python SHAREDIR=$HOME/share
-
- default_flavor () {
-@@ -73,7 +73,7 @@ if [ $? -ne 0 ]; then exit $?; fi
-
- chmod +x $TARGET$BINDIR/cropgui
-
--if [ -z "$TARGET" ] && ! (cd /tmp; python -c 'import cropgui_common') > /dev/null 2>&1; then
-+if [ -z "$TARGET" ] && ! (cd /tmp; $PYTHON -c 'import cropgui_common') > /dev/null 2>&1; then
- echo "*** Failed to import cropgui_common.py"
- echo " You must add $LIBDIR to PYTHONPATH"
- exit 1
---
-2.6.1
-