summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThibault Porteboeuf2015-08-13 14:42:58 +0200
committerThibault Porteboeuf2015-08-13 15:34:01 +0200
commit08a02e49933cd509fdcbb2899aa38a6155ca889d (patch)
treed73ab6b68f8b2b2be6f162330374357894f1f8f8
downloadaur-08a02e49933cd509fdcbb2899aa38a6155ca889d.tar.gz
Added cross-mingw-w64-gdb sources
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ed333a2c4c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = cross-mingw-w64-gdb
+ pkgdesc = The GNU Debugger (compiled to debug target mingw-w64)
+ pkgver = 7.9.1
+ pkgrel = 1
+ url = http://www.gnu.org/software/gdb/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = gcc
+ makedepends = texinfo
+ depends = ncurses
+ depends = expat
+ depends = xz
+ depends = readline
+ options = staticlibs
+ options = !buildflags
+ source = http://ftp.gnu.org/gnu/gdb/gdb-7.9.1.tar.xz
+ md5sums = 35374c77a70884eb430c97061053a36e
+
+pkgname = cross-mingw-w64-gdb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3279c2539383
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+pkgname=cross-mingw-w64-gdb
+pkgver=7.9.1
+pkgrel=1
+pkgdesc="The GNU Debugger (compiled to debug target mingw-w64)"
+arch=('i686' 'x86_64')
+url="http://www.gnu.org/software/gdb/"
+license=('LGPL')
+depends=('ncurses' 'expat' 'xz' 'readline')
+makedepends=('gcc' 'texinfo')
+options=('staticlibs' '!buildflags')
+source=("http://ftp.gnu.org/gnu/gdb/gdb-${pkgver}.tar.xz")
+md5sums=('35374c77a70884eb430c97061053a36e')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "$srcdir/gdb-$pkgver"
+ for _arch in ${_architectures}; do
+ unset LDFLAGS
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ../configure --prefix=/usr \
+ --target=${_arch} \
+ --enable-lto \
+ --disable-nls \
+ --with-system-readline \
+ --with-expat
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir"/gdb-${pkgver}/build-${_arch}
+ make install DESTDIR="$pkgdir"
+ rm -rf "$pkgdir"/usr/share/{info,locale,gdb}
+ rm -f "$pkgdir"/usr/share/man/man1/*-w64-mingw32-gdbserver.1*
+ rm -rf "$pkgdir"/usr/share/man/man5
+ rm -rf "$pkgdir"/usr/lib
+ rm -rf "$pkgdir"/usr/include
+ done
+}
+
+# vim: set expandtab tabstop=4 :