summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyak2015-08-11 18:06:04 +0300
committerkyak2015-08-11 18:06:04 +0300
commitd9114cae80ff782fa262652a86051ce0f8618b8a (patch)
tree28abf8002bb4d679f58c41d820ae2c83ef55fe24
downloadaur-d9114cae80ff782fa262652a86051ce0f8618b8a.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD63
2 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00dc9168db82
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = cross-mipsel-linux-gnu-gcc
+ pkgdesc = The GNU Compiler Collection for the MIPS architecture
+ pkgver = 4.9.2
+ pkgrel = 1
+ url = http://www.gnu.org/software/gcc/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = mpfr
+ depends = gmp
+ depends = libmpc
+ depends = sh
+ depends = cross-mipsel-linux-gnu-binutils
+ options = !ccache
+ options = !distcc
+ options = !emptydirs
+ options = !libtool
+ options = !strip
+ source = ftp://ftp.gnu.org/gnu/gcc/gcc-4.9.2/gcc-4.9.2.tar.bz2
+ md5sums = 4df8ee253b7f3863ad0b86359cd39c43
+
+pkgname = cross-mipsel-linux-gnu-gcc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1fa9a88542be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Contributor: Vojtech Horky <vojta . horky at-symbol seznam . cz>
+pkgname=cross-mipsel-linux-gnu-gcc
+_pkgname=gcc
+_target="mipsel-linux-gnu"
+pkgver=4.9.2
+pkgrel=1
+pkgdesc="The GNU Compiler Collection for the MIPS architecture"
+url="http://www.gnu.org/software/gcc/"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('mpfr' 'gmp' 'libmpc' 'sh' "cross-${_target}-binutils")
+options=('!ccache' '!distcc' '!emptydirs' '!libtool' '!strip')
+source=("ftp://ftp.gnu.org/gnu/gcc/gcc-${pkgver}/${_pkgname}-${pkgver}.tar.bz2")
+md5sums=('4df8ee253b7f3863ad0b86359cd39c43')
+_sysroot="/usr/lib/cross-${_target}"
+
+prepare() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+
+ # Hack - see native package for details
+ sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
+}
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+
+ ./configure \
+ "--prefix=${_sysroot}" \
+ "--bindir=/usr/bin" "--program-prefix=${_target}-" \
+ "--with-sysroot=${_sysroot}" \
+ "--target=${_target}" \
+ --oldincludedir=/../../../usr/include \
+ --with-gnu-as --with-gnu-ld \
+ --disable-nls --disable-threads \
+ --enable-languages=c,c++ \
+ --disable-multilib --disable-libgcj \
+ --enable-lto --disable-werror \
+ --without-headers --disable-shared
+
+ make all-gcc "inhibit_libc=true"
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+
+ make DESTDIR=${pkgdir} install-gcc
+
+ msg "Removing duplicit files..."
+ # remove these files as they are already in the system
+ # (with native gcc)
+ rm -Rf ${pkgdir}${_sysroot}/{man,info}
+ # remove conflicting binaries
+ find ${pkgdir}/usr/bin/ -type f -not -name "${_target}-*" -delete
+
+ msg "Creating out-of-path executables..."
+ # symlink executables to single directory with no-arch-prefix name
+ mkdir -p ${pkgdir}/usr/bin/cross/${_target}/;
+ cd ${pkgdir}/usr/bin/cross/${_target}/;
+ for bin in ${pkgdir}/usr/bin/${_target}-*; do
+ bbin=`basename "$bin"`;
+ ln -s "/usr/bin/${bbin}" `echo "$bbin" | sed "s#^${_target}-##"`;
+ done
+}