summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormrbit2015-07-15 14:19:13 +0200
committermrbit2015-07-15 14:19:13 +0200
commit9dc088fb71a6a910d2857e08c60778ee1d739ef8 (patch)
tree2c5d699760c2b8b2f6145e1a9068ebcd8c21157f
downloadaur-9dc088fb71a6a910d2857e08c60778ee1d739ef8.tar.gz
Package imported by apac-migrate
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81562570282a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = crosti
+ pkgdesc = Graphic conversion utility to create cross stitches
+ pkgver = 1.13.0
+ pkgrel = 1
+ url = https://sites.google.com/site/crostiapp/
+ arch = any
+ license = GPL
+ depends = qt4
+ source = http://sourceforge.net/projects/crosti/files/crosti%201.13.0/crosti-1.13.0-source.zip
+ md5sums = 5f71d8294eb33cbe67e9034d9516eaa8
+
+pkgname = crosti
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5048b541b857
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributer: giacomogiorgianni@gmail.com
+
+pkgname=crosti
+pkgver=1.13.0
+pkgrel=1
+pkgdesc="Graphic conversion utility to create cross stitches"
+arch=(any)
+url="https://sites.google.com/site/crostiapp/"
+license=('GPL')
+depends=('qt4')
+#source=("http://netcologne.dl.sourceforge.net/project/crosti/crosti%201.8.1/${pkgname}-${pkgver}-source.zip")
+source=("http://sourceforge.net/projects/crosti/files/crosti%20${pkgver}/${pkgname}-${pkgver}-source.zip")
+md5sums=('5f71d8294eb33cbe67e9034d9516eaa8')
+
+build() {
+ cd "${srcdir}"
+
+ qmake-qt4 $pkgname.pro -r -config release \
+ "CONFIG+=LINUX_INTEGRATED" \
+ "INSTALL_ROOT_PATH=$pkgdir/usr/" \
+ "LOWERED_APPNAME=$pkgname"
+
+ make
+}
+
+package() {
+ cd "${srcdir}"
+ make INSTALL_ROOT=${pkgdir} install
+}
+