summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGennadiy Chernyshyk2018-12-08 18:38:56 +0200
committerGennadiy Chernyshyk2018-12-08 18:38:56 +0200
commitfde18b814ea32ed2cfded3178513753317b43580 (patch)
treef5934fef6d4d4cdae3ae44dafcb859ca1d6c0caf
parentabda0b74bc9524650333b32e187821fc80c06f44 (diff)
downloadaur-fde18b814ea32ed2cfded3178513753317b43580.tar.gz
Update to 2.1.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18544d17fc21..3fd1afd2170d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = crow-translate
- pkgdesc = A simple and lightweight translator that allows to translate and say selected text using Google and Yandex translate API
- pkgver = 2.0.1
+ pkgdesc = A simple and lightweight translator that allows to translate and say selected text using Google, Yandex and Bing translate API
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/Shatur95/crow-translate
arch = x86_64
@@ -11,14 +11,14 @@ pkgbase = crow-translate
depends = qt5-x11extras
depends = gst-plugins-good
depends = openssl
- source = crow-translate.tar.gz::https://github.com/Shatur95/crow-translate/archive/2.0.1.tar.gz
- source = QOnlineTranslator-submodule.tar.gz::https://github.com/Shatur95/QOnlineTranslator/archive/1.0.1.tar.gz
+ source = crow-translate.tar.gz::https://github.com/Shatur95/crow-translate/archive/2.1.0.tar.gz
+ source = QOnlineTranslator-submodule.tar.gz::https://github.com/Shatur95/QOnlineTranslator/archive/1.1.2.tar.gz
source = QHotkey-submodule.tar.gz::https://github.com/Skycoder42/QHotkey/archive/1.2.2.tar.gz
- source = SingleApplication-submodule.tar.gz::https://github.com/itay-grudev/SingleApplication/archive/v3.0.10.tar.gz
- sha256sums = f7690a8a8750560cafe609643b999cbccb912a65c29eafbb57e0958d3939f317
- sha256sums = 516bdddc7f819cba47c5708f80952c55dd3590ae79abbb9238fc427010e9dfe9
+ source = SingleApplication-submodule.tar.gz::https://github.com/itay-grudev/SingleApplication/archive/3.0.13.tar.gz
+ sha256sums = 6843798e013a31c829d3b1109d49712464126a40280488d17413c4513978d608
+ sha256sums = 0c4dacc125c4599c7dc04b74231266cf1610cb6b3f6447cd84cf743671c06017
sha256sums = 1a5a6eb81738a8f232df2dd5c908839871077e10ca3b9a6437daf5fda53d86ad
- sha256sums = 9c8ae7431ea008c4516456615558c433940d3d0a144dc549f5aac43193b4afc0
+ sha256sums = 72f7100344f16a2fb1a148eb3705185e2a64fed0d40d6c114e1ee35342841c76
pkgname = crow-translate
diff --git a/PKGBUILD b/PKGBUILD
index a87dd71d6d44..38139992aad2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
# Maintainer: Shatur95 <genaloner@gmail.com>
pkgname=crow-translate
-pkgver=2.0.1
+pkgver=2.1.0
pkgrel=1
-pkgdesc="A simple and lightweight translator that allows to translate and say selected text using Google and Yandex translate API"
+pkgdesc="A simple and lightweight translator that allows to translate and say selected text using Google, Yandex and Bing translate API"
arch=('x86_64')
url="https://github.com/Shatur95/crow-translate"
license=('GPL3')
depends=('qt5-base' 'qt5-multimedia' 'qt5-x11extras' 'gst-plugins-good' 'openssl')
makedepends=('qt5-tools')
source=($pkgname.tar.gz::"https://github.com/Shatur95/crow-translate/archive/$pkgver.tar.gz"
- QOnlineTranslator-submodule.tar.gz::"https://github.com/Shatur95/QOnlineTranslator/archive/1.0.1.tar.gz"
+ QOnlineTranslator-submodule.tar.gz::"https://github.com/Shatur95/QOnlineTranslator/archive/1.1.2.tar.gz"
QHotkey-submodule.tar.gz::"https://github.com/Skycoder42/QHotkey/archive/1.2.2.tar.gz"
- SingleApplication-submodule.tar.gz::"https://github.com/itay-grudev/SingleApplication/archive/v3.0.10.tar.gz")
-sha256sums=('f7690a8a8750560cafe609643b999cbccb912a65c29eafbb57e0958d3939f317'
- '516bdddc7f819cba47c5708f80952c55dd3590ae79abbb9238fc427010e9dfe9'
+ SingleApplication-submodule.tar.gz::"https://github.com/itay-grudev/SingleApplication/archive/3.0.13.tar.gz")
+sha256sums=('6843798e013a31c829d3b1109d49712464126a40280488d17413c4513978d608'
+ '0c4dacc125c4599c7dc04b74231266cf1610cb6b3f6447cd84cf743671c06017'
'1a5a6eb81738a8f232df2dd5c908839871077e10ca3b9a6437daf5fda53d86ad'
- '9c8ae7431ea008c4516456615558c433940d3d0a144dc549f5aac43193b4afc0')
+ '72f7100344f16a2fb1a148eb3705185e2a64fed0d40d6c114e1ee35342841c76')
# Move submodules into the project
prepare() {
- mv QOnlineTranslator-1.0.1/* "$pkgname-$pkgver/src/qonlinetranslator"
+ mv QOnlineTranslator-1.1.2/* "$pkgname-$pkgver/src/qonlinetranslator"
mv QHotkey-1.2.2/* "$pkgname-$pkgver/src/third-party/qhotkey"
- mv SingleApplication-3.0.10/* "$pkgname-$pkgver/src/third-party/singleapplication"
+ mv SingleApplication-3.0.13/* "$pkgname-$pkgver/src/third-party/singleapplication"
}
build() {