summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShatur952018-03-02 19:07:48 +0200
committerShatur952018-03-02 19:07:48 +0200
commit7f869c5b3796d8155701cc29147bad5fd2027b78 (patch)
tree1f50045ad752972cd65efc8525d3fcc209a6ea94
parent0ca3eca5836f90a2931aa2dcdb7cf09fa4f4b0b5 (diff)
downloadaur-7f869c5b3796d8155701cc29147bad5fd2027b78.tar.gz
Refactor PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 350daad7c71f..cd8a8952a7a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = crow-translate-git
pkgdesc = A simple and lightweight translator that allows to translate and speak the selected text using the Google Translate API
- pkgver = r15.766cc68
+ pkgver = r26.abe8009
pkgrel = 1
url = https://github.com/Shatur95/Crow
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = crow-translate-git
depends = gst-plugins-good
depends = openssl
provides = crow
- source = git+https://github.com/Shatur95/CrowTranslate.git
+ source = crow-translate::git+https://github.com/Shatur95/CrowTranslate.git
sha256sums = SKIP
pkgname = crow-translate-git
diff --git a/PKGBUILD b/PKGBUILD
index 5c94fba6fc04..24ee76497736 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Shatur <genaloner@gmail.com>
pkgname=crow-translate-git
-pkgver=r15.766cc68
+pkgver=r26.abe8009
pkgrel=1
pkgdesc="A simple and lightweight translator that allows to translate and speak the selected text using the Google Translate API"
arch=('x86_64')
@@ -10,30 +10,33 @@ license=('GPL3')
depends=('qt5-base' 'qt5-multimedia' 'gst-plugins-good' 'openssl')
makedepends=('qt5-tools')
provides=('crow')
-source=("git+https://github.com/Shatur95/CrowTranslate.git")
+source=("${pkgname%-*}::git+https://github.com/Shatur95/CrowTranslate.git")
sha256sums=('SKIP')
# Clone submodules
prepare() {
- cd "${srcdir}/CrowTranslate"
+ cd ${pkgname%-*}
+
git submodule init
git submodule update
}
pkgver() {
- cd "${srcdir}/CrowTranslate"
+ cd ${pkgname%-*}
# Get the version number.
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}/CrowTranslate"
+ cd ${pkgname%-*}
+
qmake
make
}
package() {
- cd "${srcdir}/CrowTranslate"
+ cd ${pkgname%-*}
+
make INSTALL_ROOT="$pkgdir/" install
}