summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShatur952020-05-11 18:35:45 +0300
committerShatur952020-05-11 18:35:45 +0300
commit938dc3df40a22e4a3f3d2a6f1aea89306066793f (patch)
treea1289afdbc416a2ed5a975360a8799f742a033db
parentffa112d6530ad7e06e158798cb6ce0b85565ae2e (diff)
downloadaur-938dc3df40a22e4a3f3d2a6f1aea89306066793f.tar.gz
Update syntax
-rwxr-xr-x.SRCINFO2
-rwxr-xr-xPKGBUILD30
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d83dedcfb4c0..ff1338af7f7a 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = crow-translate-git
pkgdesc = A simple and lightweight translator that allows to translate and say selected text using the Google Translate API and much more
- pkgver = 2.3.0.r0.gc91410e
+ pkgver = 2.3.2.r0.g207e452
pkgrel = 1
url = https://github.com/crow-translate/crow-translate
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 2b07c7f92517..715440f85294 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,41 @@
# Maintainer: Shatur <genaloner@gmail.com>
pkgname=crow-translate-git
-pkgver=2.3.0.r0.gc91410e
+pkgver=2.3.2.r0.g207e452
pkgrel=1
-pkgdesc="A simple and lightweight translator that allows to translate and say selected text using the Google Translate API and much more"
-arch=('x86_64')
-url="https://github.com/crow-translate/crow-translate"
-license=('GPL3')
-depends=('qt5-base' 'qt5-svg' 'qt5-multimedia' 'qt5-x11extras' 'gst-plugins-good' 'openssl')
-makedepends=('qt5-tools' 'git')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-source=("git+https://github.com/crow-translate/crow-translate")
-sha256sums=('SKIP')
+pkgdesc='A simple and lightweight translator that allows to translate and say selected text using the Google Translate API and much more'
+arch=(x86_64)
+url=https://github.com/crow-translate/crow-translate
+license=(GPL3)
+depends=(qt5-base qt5-svg qt5-multimedia qt5-x11extras gst-plugins-good openssl)
+makedepends=(qt5-tools git)
+provides=(${pkgname%-git})
+conflicts=(${pkgname%-git})
+source=(git+$url)
+sha256sums=(SKIP)
pkgver() {
- cd "${pkgname%-git}"
+ cd ${pkgname%-git}
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
# Clone submodules
prepare() {
- cd "${pkgname%-git}"
+ cd ${pkgname%-git}
git submodule init
git submodule update
}
build() {
- cd "${pkgname%-git}"
+ cd ${pkgname%-git}
qmake
make
}
package() {
- cd "${pkgname%-git}"
+ cd ${pkgname%-git}
make INSTALL_ROOT="$pkgdir/" install
}