summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShatur952018-02-27 14:37:51 +0200
committerShatur952018-02-27 14:37:51 +0200
commitee2a26ec12a85ded37fdb4e40fae9983a55dbae6 (patch)
tree1f51c83ab6e5bb9f61408712386bbd61b1e2a5b8
downloadaur-ee2a26ec12a85ded37fdb4e40fae9983a55dbae6.tar.gz
Initial release
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..350daad7c71f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = crow-translate-git
+ pkgdesc = A simple and lightweight translator that allows to translate and speak the selected text using the Google Translate API
+ pkgver = r15.766cc68
+ pkgrel = 1
+ url = https://github.com/Shatur95/Crow
+ arch = x86_64
+ license = GPL3
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = qt5-multimedia
+ depends = gst-plugins-good
+ depends = openssl
+ provides = crow
+ source = git+https://github.com/Shatur95/CrowTranslate.git
+ sha256sums = SKIP
+
+pkgname = crow-translate-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e17d70067c4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Shatur95 <genaloner@gmail.com>
+
+pkgname=crow-translate-git
+pkgver=r15.766cc68
+pkgrel=1
+pkgdesc="A simple and lightweight translator that allows to translate and speak the selected text using the Google Translate API"
+arch=('x86_64')
+url="https://github.com/Shatur95/Crow"
+license=('GPL3')
+depends=('qt5-base' 'qt5-multimedia' 'gst-plugins-good' 'openssl')
+makedepends=('qt5-tools')
+provides=('crow')
+source=("git+https://github.com/Shatur95/CrowTranslate.git")
+sha256sums=('SKIP')
+
+# Clone submodules
+prepare() {
+ cd "${srcdir}/CrowTranslate"
+ git submodule init
+ git submodule update
+}
+
+pkgver() {
+ cd "${srcdir}/CrowTranslate"
+
+ # Get the version number.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/CrowTranslate"
+ qmake
+ make
+}
+
+package() {
+ cd "${srcdir}/CrowTranslate"
+ make INSTALL_ROOT="$pkgdir/" install
+}