summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorstefan0xC2022-10-16 12:28:42 +0200
committerstefan0xC2022-10-16 12:28:42 +0200
commit9e736b0f48e4826ac3bd75c65e0b258ec0edd669 (patch)
treebefeddb360dd65bf05cfb47af39b6a75fb62b22f
parent2d8d3fcc28668377c6a5e2d365bf6fce39a609b7 (diff)
downloadaur-9e736b0f48e4826ac3bd75c65e0b258ec0edd669.tar.gz
update dependencies to fix issue with rust 1.64
This is necessary until a new version with updated depencies is released. Old dependencies cannot be build because of a breaking change: https://blog.rust-lang.org/2022/09/22/Rust-1.64.0.html#compatibility-notes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 745ff5b30318..8ec7cbdc5121 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = crowbook
pkgdesc = Converts books written in Markdown to HTML, LaTeX/PDF and EPUB
pkgver = 0.15.2e
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/lise-henry/crowbook
arch = x86_64
license = LGPL
diff --git a/PKGBUILD b/PKGBUILD
index 43bd8d799394..2ad7ff209405 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=crowbook
pkgver=0.15.2e
-pkgrel=5
+pkgrel=6
pkgdesc="Converts books written in Markdown to HTML, LaTeX/PDF and EPUB"
arch=('x86_64')
url="https://github.com/lise-henry/crowbook"
@@ -15,6 +15,9 @@ md5sums=('SKIP')
prepare() {
cd "$srcdir/$pkgname"
export RUSTUP_TOOLCHAIN=stable
+ # Update needed to fix build issues caused by a breaking change in Rust 1.64:
+ # https://blog.rust-lang.org/2022/09/22/Rust-1.64.0.html#compatibility-notes
+ cargo update
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}