summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSenya2020-05-25 00:06:02 +0300
committerSenya2020-05-25 00:06:02 +0300
commit22cca5502af776cd86382325d789186ba43abd24 (patch)
tree0c0a893db5e652123b0a835540822a3b39116c6b
downloadaur-22cca5502af776cd86382325d789186ba43abd24.tar.gz
Initial version of package for crowdin-cli-3
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
-rwxr-xr-xcrowdin3
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9c3cebcd4da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = crowdin-cli
+ pkgdesc = Command line tool that allows you to manage and synchronize localization resources with your Crowdin project
+ pkgver = 3.1.13.r3.g0911157
+ pkgrel = 1
+ url = https://support.crowdin.com/cli-tool/
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = java-environment>=8
+ makedepends = gradle
+ depends = java-runtime>=8
+ source = git+https://github.com/crowdin/crowdin-cli.git#branch=cli3
+ md5sums = SKIP
+
+pkgname = crowdin-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..061b24eb5cfa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Senya <senya at riseup.net>
+pkgname=crowdin-cli
+pkgver=3.1.13.r3.g0911157
+pkgrel=1
+pkgdesc="Command line tool that allows you to manage and synchronize localization resources with your Crowdin project"
+url="https://support.crowdin.com/cli-tool/"
+license=('MIT')
+depends=('java-runtime>=8')
+makedepends=('git' 'java-environment>=8' 'gradle')
+conflicts=('crowdin-cli-bin')
+arch=('any')
+md5sums=('SKIP')
+
+source=(
+ 'git+https://github.com/crowdin/crowdin-cli.git#branch=cli3'
+)
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ gradle buildCrowdinCliJar
+}
+
+package()
+{
+ cd "$srcdir"
+ install -Dm 0644 "$srcdir/$pkgname"/build/libs/crowdin-cli-*.jar "$pkgdir"/usr/share/java/$pkgname/crowdin-cli.jar
+ install -Dm 0755 "$startdir"/crowdin "$pkgdir"/usr/bin/crowdin
+}
+
diff --git a/crowdin b/crowdin
new file mode 100755
index 000000000000..9debaedb94e2
--- /dev/null
+++ b/crowdin
@@ -0,0 +1,3 @@
+#!/bin/sh
+exec /usr/bin/java -jar '/usr/share/java/crowdin-cli/crowdin-cli.jar' "$@"
+