summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSenya2020-05-26 22:45:24 +0300
committerSenya2020-05-26 22:45:24 +0300
commit2dce1045ea81b1a5a93542f86111041d7766ea35 (patch)
treeb4ed35dc38c2449a01456e15c12fda1973b4f883
parente26c6c526305dbcde8803dd765a4c5ee4c3b6895 (diff)
downloadaur-2dce1045ea81b1a5a93542f86111041d7766ea35.tar.gz
Use release version as it is not a -git package
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 073c837744af..ca8cbfb60a49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = crowdin-cli
pkgdesc = Command line tool that allows you to manage and synchronize localization resources with your Crowdin project
- pkgver = 3.1.13.r3.g0911157
- pkgrel = 2
+ pkgver = 3.1.13
+ pkgrel = 1
url = https://support.crowdin.com/cli-tool/
arch = any
license = MIT
@@ -12,8 +12,10 @@ pkgbase = crowdin-cli
makedepends = awk
depends = java-runtime>=8
conflicts = crowdin-cli-bin
- source = git+https://github.com/crowdin/crowdin-cli.git#branch=cli3
+ source = git+https://github.com/crowdin/crowdin-cli.git#tag=3.1.13
+ source = crowdin
md5sums = SKIP
+ md5sums = b018bcf51df64a8e68450cd7ac0e3838
pkgname = crowdin-cli
diff --git a/PKGBUILD b/PKGBUILD
index e97c0417cdb3..c73223cec9d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Senya <senya at riseup.net>
pkgname=crowdin-cli
-pkgver=3.1.13.r3.g0911157
-pkgrel=2
+pkgver=3.1.13
+pkgrel=1
pkgdesc="Command line tool that allows you to manage and synchronize localization resources with your Crowdin project"
url="https://support.crowdin.com/cli-tool/"
license=('MIT')
@@ -9,17 +9,13 @@ depends=('java-runtime>=8')
makedepends=('git' 'java-environment>=8' 'gradle' 'grep' 'awk')
conflicts=('crowdin-cli-bin')
arch=('any')
-md5sums=('SKIP')
+md5sums=('SKIP' 'b018bcf51df64a8e68450cd7ac0e3838')
source=(
- 'git+https://github.com/crowdin/crowdin-cli.git#branch=cli3'
+ "git+https://github.com/crowdin/crowdin-cli.git#tag=$pkgver"
+ 'crowdin'
)
-pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
build() {
cd "$srcdir/$pkgname"
gradle buildCrowdinCliJar