summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniele Bartolini2020-10-25 16:45:53 +0100
committerDaniele Bartolini2020-10-25 16:45:53 +0100
commit1c5b0d57c64b0a95b343929cfa28556a83b94b2b (patch)
tree3790aa4772dc2afd266031b6347ad6593f29f4e8
downloadaur-1c5b0d57c64b0a95b343929cfa28556a83b94b2b.tar.gz
Crown v0.39.0
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD42
-rw-r--r--crown.desktop12
-rwxr-xr-xcrown.sh5
5 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db486abc4c7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = crown
+ pkgdesc = The Flexible Game Engine
+ pkgver = 0.39.0
+ pkgrel = 1
+ url = https://github.com/dbartolini/crown
+ arch = x86_64
+ license = MIT
+ depends = glib2>=2.48.2
+ depends = gtk3>=3.16
+ depends = libgl
+ depends = libpulse
+ depends = libx11
+ depends = libxrandr
+ replaces = pepper
+ source = https://github.com/dbartolini/crown/releases/download/v0.39.0/crown-0.39.0-linux-x64.tar.gz
+ source = crown.sh
+ source = crown.desktop
+ sha256sums = a9f9674b0df3af56415d25d682e20bcc3f6875052c13f7d751c811fabb87ba89
+ sha256sums = 96f19db60857c1a4db31f1d115ad77b99f6c11aecbab4239f2adcb98cac66d78
+ sha256sums = e8950a977117d524b56c5103126938430d787dbada535c9efaba266666ad3624
+
+pkgname = crown
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..44f27c04b1e5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41d9b5638400
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Daniele Bartolini <dbartolini.aa gmail com> - https://github.com/dbartolini
+
+replaces=('pepper')
+pkgname=crown
+pkgver=0.39.0
+pkgrel=1
+pkgdesc="The Flexible Game Engine"
+arch=(x86_64)
+url="https://github.com/dbartolini/crown"
+license=('MIT')
+depends=('glib2>=2.48.2'
+ 'gtk3>=3.16'
+ 'libgl'
+ 'libpulse'
+ 'libx11'
+ 'libxrandr'
+ )
+source=("https://github.com/dbartolini/crown/releases/download/v$pkgver/$pkgname-$pkgver-linux-x64.tar.gz"
+ "crown.sh"
+ "crown.desktop"
+ )
+sha256sums=('a9f9674b0df3af56415d25d682e20bcc3f6875052c13f7d751c811fabb87ba89'
+ '96f19db60857c1a4db31f1d115ad77b99f6c11aecbab4239f2adcb98cac66d78'
+ 'e8950a977117d524b56c5103126938430d787dbada535c9efaba266666ad3624')
+
+package() {
+ install -d "$pkgdir"/opt
+ cp -r $pkgname-$pkgver $pkgdir/opt/$pkgname
+
+ # Launcher
+ install -D -m755 crown.sh "${pkgdir}/usr/bin/crown"
+
+ # License
+ install -D -m644 $pkgname-$pkgver/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # .desktop and icons
+ install -D -m644 crown.desktop "${pkgdir}/usr/share/applications/crown.desktop"
+ # for _res in 256x256 128x128 64x64 32x32 24x24 16x16; do
+ # install -D -m644 $pkgname/tools/icons/$_res/pepper.png "${pkgdir}/usr/share/icons/hicolor/$_res/apps/pepper.png"
+ # done
+ # install -D -m644 pepper.svg "${pkgdir}/usr/share/icons/hicolor/scalable/apps/pepper.svg"
+}
diff --git a/crown.desktop b/crown.desktop
new file mode 100644
index 000000000000..53c9693ea1db
--- /dev/null
+++ b/crown.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Crown
+GenericName=Game Engine
+Comment=The Flexible Game Engine
+Exec=crown
+TryExec=crown
+Icon=crown
+Terminal=false
+Categories=Development;Graphics;
+StartupNotify=true
diff --git a/crown.sh b/crown.sh
new file mode 100755
index 000000000000..bfbaf847590c
--- /dev/null
+++ b/crown.sh
@@ -0,0 +1,5 @@
+#! /bin/bash
+
+CROWN=/opt/crown
+
+cd $CROWN && ./crown "$@" &