summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorusrmusicman2022-05-27 23:15:06 -0400
committerusrmusicman2022-05-27 23:15:06 -0400
commit2d2d4c7cdb12583dd24b9a8e60e2cd8044429e3a (patch)
tree5cf846b369a0656287a4a9e2430d10aaa62c7b17
downloadaur-2d2d4c7cdb12583dd24b9a8e60e2cd8044429e3a.tar.gz
Initial Release
-rw-r--r--.SRCINFO18
-rwxr-xr-xCrown EX Amp.desktop9
-rwxr-xr-xPKGBUILD39
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c799cf80a08f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = crown-ex-amp-bin
+ pkgdesc = Audio Assault Modern High Gain Amp Simulator Next Generation
+ pkgver = 22.05.27
+ pkgrel = 1
+ url = https://audioassault.mx/products/sigma
+ arch = x86_64
+ groups = pro-audio
+ groups = vst-plugins
+ groups = vst3-plugins
+ license = EULA
+ makedepends = xdg-user-dirs
+ makedepends = unzip
+ depends = libcurl-gnutls
+ depends = glibc
+ source = Crown EX Amp.desktop
+ sha256sums = 9ee179709bce7be2eab743547c78a8c3312a6fe5b72fa2beef498283fad05b2a
+
+pkgname = crown-ex-amp-bin
diff --git a/Crown EX Amp.desktop b/Crown EX Amp.desktop
new file mode 100755
index 000000000000..98e75836993c
--- /dev/null
+++ b/Crown EX Amp.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Comment=Audio Assault 3 Channel Californian Amp Sim Next Generation
+Type=Application
+Categories=AudioVideo;X-AudioEditing
+Terminal=false
+Exec="/usr/bin/The Crown EX Standalone"
+Name=Crown EX Guitar Amp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..02d26624569c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=crown-ex-amp-bin
+pkgver=22.05.27
+pkgrel=1
+pkgdesc="Audio Assault Modern High Gain Amp Simulator Next Generation"
+arch=('x86_64')
+url="https://audioassault.mx/products/sigma"
+license=('EULA')
+groups=('pro-audio' 'vst-plugins' 'vst3-plugins')
+depends=('libcurl-gnutls' 'glibc')
+makedepends=('xdg-user-dirs' 'unzip')
+source=("Crown EX Amp.desktop")
+sha256sums=('9ee179709bce7be2eab743547c78a8c3312a6fe5b72fa2beef498283fad05b2a')
+
+prepare () {
+ ## Extract Duality Bass Studio
+ _archive="`xdg-user-dir DOWNLOAD`/TheCrownEXv1_0_Installers.zip"
+ ln -srf "${_archive}" "$srcdir/`basename "${_archive}"`"
+ unzip "$srcdir/`basename "${_archive}"`"
+ unzip "TheCrownEXv1_0_Installers.zip"
+ find $srcdir -name ".DS_Store" -delete
+}
+
+package() {
+ ## Install Preset and Default Libraries
+ mkdir -p "$pkgdir/opt/Audio Assault/The Crown EX" "$pkgdir/usr/bin" "$pkgdir/usr/share/applications"
+ cp -rf "$srcdir/The Crown EX Linux/The Crown EX"/{IRs,MIDI,Presets} "$pkgdir/opt/Audio Assault/The Crown EX"
+
+ ## Install VST Plugin
+ install -Dm755 "$srcdir/The Crown EX Linux/The Crown EX.so" "$pkgdir/usr/lib/vst/The Crown EX.so"
+
+ ## Install VST3 Plugin
+ mkdir -p "$pkgdir/usr/lib/vst3"
+ cp -r "$srcdir/The Crown EX Linux/The Crown EX.vst3" "$pkgdir/usr/lib/vst3/The Crown EX.vst3"
+
+ ## Install Standalone Binary
+ cp "$srcdir/The Crown EX Linux/The Crown EX Standalone" "$pkgdir/usr/bin/The Crown EX Standalone"
+ chmod +x "$pkgdir/usr/bin/The Crown EX Standalone"
+ install -Dm644 "$srcdir/Crown EX Amp.desktop" "$pkgdir/usr/share/applications/Crown EX Amp.desktop"
+}