summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Preinstorfer2021-07-06 21:20:28 +0200
committerFlorian Preinstorfer2021-07-06 21:20:28 +0200
commit833a50c0be215e4f1d7540c1d9dae9e3c3afba1b (patch)
treeec205c2bf25c56e5586a24c2f5943bec17b6df3c
parentfa54e8c6cb418d0561b8ffd5364a5b4a45b2d57a (diff)
downloadaur-833a50c0be215e4f1d7540c1d9dae9e3c3afba1b.tar.gz
Cruft 2.9.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d924978b81f..e920d3336feb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cruft
pkgdesc = Maintain all the necessary boilerplate for packaging and building projects separate from the code you intentionally write. Fully compatible with existing Cookiecutter templates
- pkgver = 2.8.0
+ pkgver = 2.9.0
pkgrel = 1
url = https://cruft.github.io/cruft/
arch = any
@@ -12,9 +12,8 @@ pkgbase = cruft
depends = python-gitpython
depends = python-typer
optdepends = python-toml: specify patterns to ignore in toml files
- source = https://files.pythonhosted.org/packages/source/c/cruft/cruft-2.8.0.tar.gz
- sha1sums = bd940e2da3c6f4471a8ec841dba715616b2fb20d
- sha256sums = 29e6c95ed46bda8d26b9666e78bdcd625f3a2352620fc52c44dc4ff64a298ce0
+ source = https://files.pythonhosted.org/packages/source/c/cruft/cruft-2.9.0.tar.gz
+ sha1sums = 23c39f589b77ce7c90428a8ff71211dd55a1d3c3
+ sha256sums = 550703c35b8125612ad89d93d176f29b3e362c19c74ed28895625afa9010fcb1
pkgname = cruft
-
diff --git a/PKGBUILD b/PKGBUILD
index e7ec8d7c96d6..2c44c13239f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,32 @@
# Maintainer: nblock <nblock [/at\] archlinux DOT us>
pkgname=cruft
-pkgver=2.8.0
+pkgver=2.9.0
pkgrel=1
pkgdesc='Maintain all the necessary boilerplate for packaging and building projects separate from the code you intentionally write. Fully compatible with existing Cookiecutter templates'
arch=('any')
url='https://cruft.github.io/cruft/'
license=('MIT')
depends=('python'
- 'python-click'
- 'python-cookiecutter'
- 'python-gitpython'
- 'python-typer')
+ 'python-click'
+ 'python-cookiecutter'
+ 'python-gitpython'
+ 'python-typer')
optdepends=('python-toml: specify patterns to ignore in toml files')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha1sums=('bd940e2da3c6f4471a8ec841dba715616b2fb20d')
-sha256sums=('29e6c95ed46bda8d26b9666e78bdcd625f3a2352620fc52c44dc4ff64a298ce0')
+sha1sums=('23c39f589b77ce7c90428a8ff71211dd55a1d3c3')
+sha256sums=('550703c35b8125612ad89d93d176f29b3e362c19c74ed28895625afa9010fcb1')
build() {
- cd "$pkgname-$pkgver"
- python setup.py build
+ cd "$pkgname-$pkgver"
+ python setup.py build
}
package() {
- cd "$pkgname-$pkgver"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cd "$pkgname-$pkgver"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
# vim:set ts=2 sw=2 noet: