summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Preinstorfer2020-09-12 17:29:44 +0200
committerFlorian Preinstorfer2020-09-12 17:29:44 +0200
commitf276bce79d7bf6559602b20fa120492a039c5c1f (patch)
tree84eb7da9f1666d901b3ed75f244debe582a19583
downloadaur-f276bce79d7bf6559602b20fa120492a039c5c1f.tar.gz
Release 2.3.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab096355002f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = cruft
+ pkgdesc = Maintain all the necessary boilerplate for packaging and building projects separate from the code you intentionally write. Fully compatible with existing Cookiecutter templates
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = https://cruft.github.io/cruft/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-click
+ depends = python-cookiecutter
+ depends = python-gitpython
+ depends = python-typer
+ optdepends = python-toml: specify patterns to ignore in toml files
+ source = https://files.pythonhosted.org/packages/source/c/cruft/cruft-2.3.0.tar.gz
+ sha1sums = 61a7ace5acbaf7ee356502ddd0d59a8a592ad83f
+ sha256sums = 7c0f7682765e76fcf31adf877ea6f74372a0ab9554d8f8d6766e8e0413730e52
+
+pkgname = cruft
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0375d7ad17d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: nblock <nblock [/at\] archlinux DOT us>
+
+pkgname=cruft
+pkgver=2.3.0
+pkgrel=1
+pkgdesc='Maintain all the necessary boilerplate for packaging and building projects separate from the code you intentionally write. Fully compatible with existing Cookiecutter templates'
+arch=('any')
+url='https://cruft.github.io/cruft/'
+license=('MIT')
+depends=('python'
+ 'python-click'
+ 'python-cookiecutter'
+ 'python-gitpython'
+ 'python-typer')
+optdepends=('python-toml: specify patterns to ignore in toml files')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha1sums=('61a7ace5acbaf7ee356502ddd0d59a8a592ad83f')
+sha256sums=('7c0f7682765e76fcf31adf877ea6f74372a0ab9554d8f8d6766e8e0413730e52')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+
+# vim:set ts=2 sw=2 noet: