summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSammysHP2015-08-21 23:57:30 +0200
committerSammysHP2015-08-21 23:57:30 +0200
commit9c15075c991bfc38ec1060a726414d884bf7b075 (patch)
treeb7228f2aa1c17d0775b5536a05c181766f301000
downloadaur-9c15075c991bfc38ec1060a726414d884bf7b075.tar.gz
Update to version 1.1.14-1
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD21
-rwxr-xr-xatlas-maps.sh2
4 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b167746e73f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = atlas-maps-bin
+ pkgdesc = Map and navigation application using offline vector maps
+ pkgver = 1.1.14
+ pkgrel = 1
+ url = http://wiki.openstreetmap.org/wiki/Atlas_(navigation_application)
+ arch = any
+ license = proprietary (free)
+ depends = java-runtime
+ provides = atlas-maps
+ conflicts = atlas-maps
+ source = http://www.talent.gr/public/atlas/Atlas-1.1.14.zip
+ source = atlas-maps.sh
+ md5sums = b662c6a3fe2029d7c022c463c8e4b35e
+ md5sums = 509caab1fb6ad3990e87890a5dfb7d81
+
+pkgname = atlas-maps-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82572c742947
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tar.xz
+*.tar.gz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b5524a54e34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Sven Karsten Greiner <sven@sammyshp.de>
+
+pkgname=atlas-maps-bin
+pkgver=1.1.14
+pkgrel=1
+pkgdesc="Map and navigation application using offline vector maps"
+arch=('any')
+url="http://wiki.openstreetmap.org/wiki/Atlas_(navigation_application)"
+license=('proprietary (free)')
+depends=('java-runtime')
+provides=('atlas-maps')
+conflicts=('atlas-maps')
+source=("http://www.talent.gr/public/atlas/Atlas-${pkgver}.zip"
+ "atlas-maps.sh")
+md5sums=('b662c6a3fe2029d7c022c463c8e4b35e'
+ '509caab1fb6ad3990e87890a5dfb7d81')
+
+package() {
+ install -Dm644 "Atlas-${pkgver}/Atlas.jar" "$pkgdir/usr/share/java/atlas-maps/atlas.jar"
+ install -Dm755 atlas-maps.sh "$pkgdir/usr/bin/atlas-maps"
+}
diff --git a/atlas-maps.sh b/atlas-maps.sh
new file mode 100755
index 000000000000..5a17ec9201f4
--- /dev/null
+++ b/atlas-maps.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+java -jar /usr/share/java/atlas-maps/atlas.jar