summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWyatt2023-10-03 22:00:02 -0400
committerWyatt2023-10-03 22:00:02 -0400
commit75feae4e24ea4f98928d9cd4b6081c9571aa1263 (patch)
treecd49c1b342c3015db5b968801c1f029f146a06e6
downloadaur-75feae4e24ea4f98928d9cd4b6081c9571aa1263.tar.gz
first commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD56
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0103af7333c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = crumb
+ pkgdesc = Crumb is a high level, functional, interpreted, dynamically typed, general-purpose programming language, with a terse syntax, and a verbose standard library.
+ pkgver = 1.0
+ pkgrel = 1.0
+ url = https://github.com/liam-ilan/crumb/tree/main/src
+ arch = x86_64
+ license = GPL
+ makedepends = gcc
+ makedepends = coreutils
+ source = crumb::git+https://github.com/liam-ilan/crumb.git
+ md5sums = SKIP
+
+pkgname = crumb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd4947a39b11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Wyatt Kinard wyattkinard@skiff.com
+
+#Atention:
+#I did not create crumb, nor do I maintain it (not a lot anyways), but I maintain the aur package
+#
+#
+pkgname=crumb
+pkgver=1.0
+pkgrel=1.0
+epoch=
+pkgdesc="Crumb is a high level, functional, interpreted, dynamically typed, general-purpose programming language, with a terse syntax, and a verbose standard library."
+arch=('x86_64')
+url="https://github.com/liam-ilan/crumb/tree/main/src"
+license=('GPL')
+groups=()
+depends=()
+makedepends=('gcc'
+'coreutils')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=('crumb::git+https://github.com/liam-ilan/crumb.git')
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+prepare() {
+ cd "$srcdir"
+# patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
+}
+
+build() {
+ cd crumb/src
+ gcc *.c -Wall -lm -o crumb
+}
+
+check() {
+ echo almost done...
+}
+package() {
+ cd crumb/src
+ sudo mv crumb /usr/bin
+}
+
+